1

I'm in a bit of a predicament. Once upon a time, I installed rEFInd on my 2012 Mac Pro. I eventually removed it.

I believe I also once tried to install Kali Linux in a dual boot environment.

Fast forward and I have tried to follow the steps in this guide to make a Windows-bootable external drive.

My final (and fatal) step was selecting the Windows disk in "Startup Disk" in System Preferences like so:

startup disk

...except it said "Untitled" instead of BOOTCAMP. Also not to confuse you, I am running 10.12.3 and did not install Bootcamp.

Upon restarting, my Mac Pro passes POST and chimes, but boots to a white/gray screen with NO logo, and then proceeds to run some sort of ISOLINUX bootloader that then presents me with the Kali Linux efi splash screen that does not respond to input:

kali-boot-screen

That was very unexpected, so I shut it down, pulled all the hard drives, every last one, and rebooted. Same behavior.

I'm a little worried, because clearly something has been written to the NVRAM onboard, and it is not responding to my Cmd + Opt + P + R

Also the Mac bootloader is not showing up. It does not respond to any keyboard input. Holding Opt does nothing.

How do I get out of this?

  • When turning on your Mac, hold Opt. You will get the Apple Boot Manager. – Allan Sep 2 '17 at 12:07
  • I do not get the boot manager anymore. White screen, then straight to ISOLINUX loader... Mac is unresponsive to any keyboard input. And like I said, I pulled all the hard drives. – DrKumar Sep 2 '17 at 23:07
1

Considering that you are only seeing a gray screen with no logo or symbol at all, I'd try some of these starts options, as well as macOS Recovery to repair your Macintosh HD volume if needed.

There are a few things you could do at startup. First, you could hold Option on the keyboard immediately after powering on your Mac, and you should be presented with a screen with a list of volumes to boot you Mac from. Choose Macintosh HD from the list. Have a look at: How to set up and use an external Mac startup disk

Next, you could hold the X key immediately after powering on your Mac in order to force the machine to attempt to boot from the internal macOS volume.

Lastly, you could hold CommandR in order to access macOS Recovery. This would allow you to check your Mac's disk configuration and even repair the macOS volume if needed. In recovery mode, you can also change your startup disk:

To quit macOS Recovery, choose Restart or Shut Down from the Apple () menu. If you want to choose a different startup disk before quitting, choose Startup Disk from the Apple menu.

Have a look at: About macOS Recovery

You can find more startup options here: Startup key combinations for Mac

UPDATE: I was able to find an answer that seems to address rEFInd allowing your Mac to boot into neither Recovery nor macOS: Kali Linux auto boot
I understand that you did remove rEFInd, but this may be worth looking into.

  • I do not have access to any boot options whatsoever. No combination of key commands change the boot process. – DrKumar Sep 2 '17 at 23:09
  • Just to clarify, you cannot even access Recovery mode? I see that you have tried to reset the NVRAM, but I would try that again as well as reset the SMC. Are you using a USB keyboard when booting up? It may be necessary to take your Mac to an Apple store or authorized repair shop to get it looked at. – Jake3231 Sep 2 '17 at 23:33
  • I was able to find an answer from a different question that may be able to better resolve this issue. – Jake3231 Sep 2 '17 at 23:49
  • I have reset the SMC. I am unable to use a keyboard when booting up. I have been able to successfully boot a Windows live CD as well as an Ubuntu live CD on my mac by holding down the mouse button when booting to open the disk drive. I burned a Yosemite install disc by following these steps but that was the only disc not recognized. I tried installing rEFInd again by using Ubuntu, but it won't see any EFI partition on boot. I think some flag is set in the NVRAM and I won't be able to clear it :( – DrKumar Sep 9 '17 at 7:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .