I have an encrypted hfs+ external SSD. When I plug it into my mac and, it prompts for my password, but after I enter it nothing happens.

I tried this in terminal:

enter image description here

  • I'm experiencing the same issue, only a reboot fixes it. I'm still looking for a workaround...
    – pyrho
    Commented Jan 7, 2020 at 19:07

4 Answers 4


I ran into this. In my case it seems the problem was the mac wanted to run a filesystem check on it. After finding the fsck process and killing it, I could then mount the drive properly.

$ ps -ef | grep fsck  
$ kill [pid from above] 
  1. Maybe check to see if you have any softwares running that block mounts, such as "disk arbitrator". In my case I forget to disable it, and after quitting it my disk mounted. (However, it may not show up in Finder, depending on how the system want it to work. Go to /Volumes/ to check whether the disk is mounted.)
  2. Next, restart in another system (recovery HD may be a good option) and check whether the disk will mount or not. If it mount, than it's your system's fault.
  3. After restarting to your default system, see if it will mount. If not, try if resetting SMC, resetting NVRAM/PRAM, and booting up in safe mode works.
  4. If not, maybe reinstall the system.
  5. If all above don't work, contact Apple Support, or ask a macOS expert.

Note: What I've provided is a standard procedure to solve most minor problems. It may not work and you should backup before doing any potentially dangerous tasks.


You could try to convert the encrypted CoreStorage device back to normal using the revert keyword of diskutil cs:

diskutil cs revert <LVUUID> -stdinpassphrase

with being the UUID of the logical volume. What bothers me, however, is that diskutil cs list shows “–none–” for the Disk parameter of the SSD logical volume...

  • I finished the conversion process back to an unencrypted drive. But I'm still unable to mount it. disk3 is a CoreStorage Logical Volume which failed to mount
    – user150951
    Commented Sep 2, 2017 at 7:56
  • imageshack.com/a/img924/5223/24BVjU.png
    – user150951
    Commented Sep 2, 2017 at 8:02
  • do you have any more suggestions Tom? I tried search for solutions, but to no avail so far
    – user150951
    Commented Sep 10, 2017 at 4:32
  • @user150951: If you've gone this far without success I'm afraid you won't be abe to go any further with the built-in tools. This is when 3rd-party tools come in. DiskWarrior is highly respected for its desaster recovery festures. You might want to give it a try.
    – Tom E
    Commented Sep 10, 2017 at 10:16

The only time I've seen this I tried mounting it on a different Mac and it was successful. I wound up copying data from the drive and erasing / starting over.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .