I just installed High Sierra Developer Beta 8 on my 2015 Macbook Pro and I haven't been able to make Tuxera NTFS work with it. A few searches on Google seem to indicate that it does work with High Sierra, but all I get is an error when trying to mount my external HDD:


I read somewhere that Gatekeeper could be the source of the problem, but even after allowing it there, nothing changed. So, does anyone have any clues about what may be happening in my case?

  • 2
    A (very) good possibility is that Tuxera NTFS isn't compatible with High Sierra's APFS (Apple File System). Given that it's a 3rd Party Utility, have you contacted them for assistance/support? – Allan Aug 31 '17 at 12:08

Tuxera NTFS 2016.1 works perfectly fine on my iMac with High Seirra with older file system, but it won't work on my MacBook Pro with High Seirra with the newer APFS. I did the same thing on the MacBook as I did with the iMac so go figure.

| improve this answer | |
  • Have you gotten a hold of Tuxera? They Make no mention that APFS is a problem, only the opt in to the kernel extension. See my edit to the answer here: apple.stackexchange.com/a/302295/5472 – bmike Nov 25 '17 at 23:28

Check the System Preferences > Security & Privacy, under General tab you may need to Allow the Tuxera system component (forgot its name/details).

The Tuxera 2016.1 seems to be working for me on High Sierra/10.13.0 after allowing its system component to run under Security & Privacy, it gave error something similar, and Allowing it made it to work.

This is explained as opt in for running the kernel extension:


(*) Our 2016.1 version is compatible with High Sierra. Note that High Sierra prevents extensions from loading automatically, which means that if you use version 2016.1 you’ll need to allow the extension to run from Security preferences pane. The upcoming version of Tuxera NTFS for Mac will help you breeze through this setup. Want to be part of our beta? Email us at macsupport@tuxera.com for more info.

Since you're on a beta OS - you might want to join Tuxera's beta as well in case they'll work with you on debugging any issues before their tool and the macOS version you run are released.

| improve this answer | |
  • I was using Better Touch Tool, which might interfere with the Allow button. I had to go to keyboard settings and enable keyboard for all interface items, then I could tab to "Allow" and click it with space bar. Mouse and Touch pad were not working. – Aaron McMillin Nov 14 '18 at 4:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .