0

I have bought a new Magic Keyboard in Portugal to replace my previous one as I spilled coffee on it! Now I find many of the keys produce bizarre non matching symbols. What on Earth is going on?

  • If I try to hit the question mark key all I get is this _
  • If I want an apostrophe I get - instead
  • The bracket keys are out of order and I struggle to find what I need.
  • ; is found by hitting a key to the right of L but it marked with a another option.
  • The key next to that is a ^ yet gives me " or '
  • Magic keyboards work with macOS and ios and other computers. If you aren’t on a Mac like one answers has guessed, please edit this to explain with what you are using the keyboard. – bmike Aug 31 '17 at 11:01
1

The problem is that your Keyboard layout is set to Brazilian and not to the Layout that you are used to..

Go to System Settings -> Keyboard -> Input Sources...

There you will see that its the wrong input source. To change it click on the plus symbol (+) in the left corner of the list and add the input source you want.


  • Why do you think it is set to brazilian? The behavior described is more like a Portuguese keyboard set to US. Also it will do nothing at all to just add some layout to the input sources list, unless the user goes to the "flag" menu at top right of the screen and makes sure the right one is selected. The right answer is probably to go to the input sources list and remove all items except Portuguese, so the output will match what is printed on the keys. – Tom Gewecke Aug 31 '17 at 11:40
  • First I tried it with a Portuguese layout but everything worked just fine for me. So I added the Brazilian one and then tried to write a question mark, but instead a underscore was written... And yes obviously you have to select the layout you want (for me its Swiss-German and in the picture I selected it) Please people, think a little bit by your own – M Lemberg Aug 31 '17 at 11:53
  • Thanks for the explanation. The layout called "brazilian" is actually the same as US. – Tom Gewecke Aug 31 '17 at 12:04
1

If you want the output of a Portuguese hardware keyboard to match what is printed on the keys in MacOS, go to system preferences/keyboard/input sources and use the plus/add buttons to make sure that ONLY Portuguese is on the list. At present it appears you have the US or Brazilian layouts there as well.

If you are using this keyboard with iOS, then you have the make sure that your Settings > General > Keyboard > Hardware Keyboards is set to Portuguese.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .