2

I have been having an issue regarding keyboard short-cut to change input source between Japanese and English on a new iMac running on Sierra. On my old Mac, I used "command+space" (Fig. 1) to change the input source, but now on Sierra I have to use "control+space" (Fig. 2), which is quite inconvenient. Could someone help me how to set my system so that I can use "command+space" to change the input source? changing input source on my old Mac running on El Capitan changing input source on my new Mac running on Sierra

4

You are in the right place, but the wrong selection.

Select "Spotlight" from the list on the left. You can then uncheck the shortcut for Command Space allowing you to assign that to the shortcut you want to.

0

Looks like it doesn't want to work on my Mojave. After unchecking Command+space for spotlight, i still don't receive option to add it to change the source input shortcut. Please, advice

  • What do mean by “don’t receive the option”? Did you double click on the existing input source shortcut to make it editable? – Tom Gewecke Feb 9 at 15:45
  • 1
    Welcome to Ask Different. Please refrain from adding comments in the Answer section. This is for answers to the questions only. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. See How to Ask for more info on how to ask a question. - From Review – fsb Feb 9 at 19:47
0

You should select shortcut you want to change and press ENTER (not double click, double click do nothing) to be able to change this selected shortcut. Work this way on Mac OS Mojave 10.14.5, don't know if its relevant for older or future version of Mac OS.

  • Do you really find that double clicking at the far right of the shortcuts item, right where the actually shortcut is shown, does nothing? Normally it should make the shortcut editable. – Tom Gewecke Jun 17 at 15:23
  • Yes, checked right now. Clicking on the far right of the shortcut item work too, same as hitting enter. It's not very obvious to double-clicking in that part of the line) Thanks for clarification! – Савельев Дмитрий Jun 18 at 13:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .