1

For some reason macOS won't obey my preferences for host name. If I set my computer name to whatiwant, then change the NETBIOS name to whatiwant and workgroup name to workgroup under WINS configuration in Network settings, when I go to Sharing in System Preferences, I see:

Other users can access shared folders on this computer, and administrators all volumes, at smb://new-host-4.workgroup.

I don't know where else I need to change the host name to stop making it use new-host-4.

I tried rebooting, but that didn't fix the problem.

This is a MacBook Pro, connecting to a home network and being assigned an IP address via DHCP on a typical broadband router. Here's the DHCP config. Perhaps the issue is related to the highlighted checkbox.

I tried renewing my DHCP lease but that didn't change the SMB hostname.

enter image description here

  • Did you try restarting? – Harv Aug 31 '17 at 1:41
  • @Harv I did, but that didn't work. Updated the question. – Swisher Sweet Aug 31 '17 at 11:43
  • 1
    To rephrase the question - are you assigning hostnames from DHCP server? – Allan Aug 31 '17 at 12:12
  • @Allan, I think that might be the issue. This is checked by default, but since I am setting a hostname in macOS, I don't understand why it's assigning its own. Renewing the lease did not solve this problem. – Swisher Sweet Aug 31 '17 at 12:18
  • 1
    In your DHCP, delete the lease, and then restart your Mac. This will force your Mac to get a new IP and name. – Allan Aug 31 '17 at 12:19
1

Did you try the local hostname setting in Sharing preferences? It's found by clicking the Edit... button in Sharing preferences.

Local hostname setting

If that doesn't work, check that the DHCP Client ID isn't set. Some DHCP servers will use it to assign a hostname.

You can find it from the Advanced section of Network Preferences, under the TCP/IP section. Make sure that you have the proper network interface you use selected when you click the Advanced button. enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .