11

Google Chrome comes by default with Hardware Acceleration enabled. This setting can be changed from the advanced settings.

I'm experiencing a very frustrating problem where most video content on Google Chrome experiences visual stutters that last up to 6 seconds. Moving the mouse seems to unfreeze the video, but it will otherwise not unfreeze until after a few seconds, only to freeze again shortly thereafter.

Disabling Hardware Acceleration eliminates the stutter. As a side-effect, all web content becomes slower and more CPU-intensive, especially pages that make use of CSS visual effects. As such, it's not viable to keep using the software without Hardware Acceleration.

I'm experiencing this problem only when using Google Chrome and only when doing so on my 2017 15" MBP. The computer is upgraded to the highest-tier hardware, so I don't suspect it's a question of underpowered hardware.

My 2012 non-retina 15" MBP also does not display this issue. One of the main differences is that I have two users logged into the MacBook at the same time, one being my personal and the other my work account. I often switch between these. This question has a similar background but no solution.

The problem also doesn't appear to be constant. Sometimes videos will play without stutter. This might be related to the automatic graphic switching. At the moment my graphics card is set to High-Performance and I can see no stuttering. I never noticed any stuttering when I tried playing the same content on Safari after experiencing stutter in Chrome.

Is there a solution to the stuttering?

Hardware/Software details:

  • Google Chrome: Version 61.0.3163.100 (Official Build) (64-bit)
  • OS: macOS Sierra: 10.12.6 (16G29)
  • Model: MacBook Pro (15-inch, 2017)
  • Processor: 3.1 GHz Intel Core i7
  • Memory: 16 GB 2133 MHz LPDDR3
  • Graphics: Radeon Pro 560 4096 MB, Intel HD Graphics 630 1536 MB
  • External Display: LG 34UC98, connected via Thunderbolt 3 to Thunderbolt 2 adapter and Thunderbolt 2 cable. Note the issue appears on both internal and external display.
  • To clarify the intent of my question, I consider disabling Hardware Acceleration a workaround and not a solution. I am looking for a way to address the core cause of the problem. Feel free to request any details you may think are important. – Gabriele Cirulli Sep 22 '17 at 11:24
  • 1
    This appears to be a Google Chrome bug. I'd rather file a bug report (Chrome > About Google Chrome > Report an issue) than expect an answer here. – klanomath Sep 22 '17 at 11:51
  • What happens with no external monitors connected (i.e. nothing but powercord)? How is kernel_task behaving while it stutters, can you see fluctuations in software.intel.com/file/553992/download Power Gadget? – LаngLаngС Sep 22 '17 at 13:05
  • Can you please specify the version of Google Chrome that you are using? – oa- Sep 22 '17 at 13:26
  • @oa- Yes, good point. Added. – Gabriele Cirulli Sep 22 '17 at 13:35
3

I had same problem and the solution is go to System Preferences > Keyboard and uncheck turn keyboard backlight off. This will make Chrome work smoothly .

  • why would turning off keyboard backlighting make chrome work smoothly... what the hell :o – WilomGfx Nov 18 '18 at 20:12
  • This is going to sound crazy but it worked. For me it started when I turned on auto dim and stopped when I disabled it. I can even see the chop in stream when the keyboard starts to dim. It happens with gifs as well. I'm sure there are a lot of reasons youtube can be choppy but this one fixed it for me. – urman Jan 13 at 15:20
2

Video will be lagging and stuttering in GC if you've got many GC plugins, use hardware acceleration option (nowadays this option still has many bugs), got outdated graphics card drivers, etc.

To fix lagging/stuttering video, try this:

  • Disable "Use hardware acceleration"
  • Browse in "Incognito Mode"
  • Delete cached files and cookies via "Clear Browsing Data..."
  • Disable unused plugins under chrome://plugins
  • Disable all extensions under chrome://extensions
  • Update graphics card drivers (use the latest update in macOS)
  • Use the default theme in Chrome
  • Reset your browser settings

Also, try Chrome Canary to see if the issue still exists there. And look at this page as well.

  • There are currently bugs related to Chrome HW-acceleration that are located in Apple's AMD drivers and supposedly fixed in High Sierra, meaning they are to stay in Sierra forever. If it's that you'll need an upgrade to the OS. – LаngLаngС Sep 24 '17 at 10:54
  • Unfortunately this issue hasn't been solved in High Sierra for me. I'm using an AMD card. What can I do to improve this? – Gabriele Cirulli Dec 1 '17 at 11:29
1

Try using the resolution that is default for the display.

I had the same issue with HW acceleration, with the latest Chrome and Mac OS updates. Reverting the display resolution to default fixed the issue for me. However, this means it's an Apple bug.

0

Go to chrome://flags/#enable-npapi

Once you've arrived, look for hardware acceleration. Turn that off and turn anything off you see related to video acceleration.

Once done, restart Chrome and the shadow will be gone and the video should no longer stutter.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .