0

I used to be able to add (or remove) users to this folder via Finder's Get Info. Today I noticed I was not able to do that anymore:

Can't Add User

When I select the Lock icon in the lower right hand corner and enter an administrator's credentials, the [+] icon in Get Info stayed disabled.

Admin Credentials

What is going on?

1 Answer 1

1

/* Posting this here in case someone else encounters a similar issue. */

This happened on a volume on an external drive. I took a look in Terminal:

Boxx:Test Alex$  ls -la /Volumes/External\ Drive/Users/Test
total 0
drwx---r-x+ 3 Test  501    101 17 Aug 18:56 .
drwx---r-x@ 6 root  admin  203 17 Aug 18:52 ..
drwx------  9 Test  501    305 26 Aug 21:00 Documents

To see if I could change anything via Terminal I tried

sudo chmod 755 /Volumes/External\ Drive/Users/Test/Documents/

and got as response

chmod: Unable to change file mode on /Volumes/External Drive/Users/Test/Documents/: Read-only file system

That then indicated to me that something was not right with the way the volume was mounted. I don't know why it mounted as read-only, but remember not seeing it at first among the volumes in Finder. So I did Shift+Command+G and entered the volume path before: Go to the folder

The volume mounted, but seemingly only as read-only.

Unmounting and re-mounting it again solved the problem above.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .