5

Whenever I open System Preferences directly to one of the subscreens (e.g. Network or Bluetooth), that screen appears for a split second, then Sys Prefs immediately jumps to the Keyboard screen. I have to Search and select the screen I want again before it will "stick."

Also, if go to another prefs screen, then click away from it to another app, Sys Prefs again consistently jumps to the keyboard screen.

Even after switching to another tab under Keyboard (Text, Shortcuts, etc.), clicking away will again jump back to the first tab (Keyboard -> Keyboard).

Happens in Sierra but also happened in El Capitan.

This makes it pretty hard to do some tasks and is extremely annoying. Haven't found any solutions online - ideas?

  • I know you mention that you haven't found any solutions online, but I'm wondering what you have tried thusfar? If possible can you edit your question to include those details. Otherwise you may get a whole heap of suggestions for things you've already tried. – Monomeeth Sep 5 '17 at 22:09
  • @Monomeeth Thanks - I haven't found anyone with similar symptoms. I tried creating a new user account and that seems to fix the issues. But I am not super keen on taking the time to transfer everything to a new account. – Luke Williams Sep 6 '17 at 15:59
  • @LukeWilliams Please add corresponding system log entries (if you find some)... – klanomath Sep 6 '17 at 23:14
  • Does this annoyance persist when you login as another user? – CousinCocaine Sep 12 '17 at 10:40
  • @CousinCocaine no, creating a new account this issue does not repro. – Luke Williams Sep 12 '17 at 15:08
3
+100

Since this issue isn't present when you create a new user account, I suggest you also test whether this behaviour is replicated in Safe Mode.

Boot into Safe Mode

Follow these steps to boot your MacBook Pro into Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. is the issue still present when accessing System Preferences)
  6. Now exit Safe Mode by restarting your Mac as normal
  7. Once logged in again, test to see whether the behaviour continues

If the problem is not present during Safe Mode and still remains when you log back in normally, it's time to investigate login items, fonts, and kernel extensions.

Investigating login items, fonts, and kernel extensions

Let's start with Login Items:

  1. Startup normally
  2. Go to System Preferences > Users & Groups
  3. Select the Login Items tab
  4. Take a note of your Login Items
  5. Now remove all of them by highlighting them and clicking on the - button below
  6. Restart your computer

Now your Mac will boot up without those login items loading. Test this and see if the problem persists:

  • If the problem goes away you know one (or more) of the Login items were causing the problem. You can then add them back in one by one until you've identified the culprit. Problem solved.
  • If the problem does persist, it's either a problem with fonts you've installed yourself or with a 3rd party kernel extension. A little more info below:

Fonts:- You can remove any of the fonts you've installed yourself to see if this makes a difference.

Kernel Extensions:- You can open Terminal (found within your Utilites folder) and enter the following command:

kextstat | grep -v com.apple

The above command will list 3rd party kernel extensions (you may need to stretch the Terminal window so it's easier to read). Look for anything you don't remember installing, or something that belongs to software you've removed, or just anything that looks out of place. Remember though, this is a list of 3rd party kernel extensions and therefore any of them could be causing the problem.

After making these changes, use your Mac long enough to see what difference, if any, they make. This is basically a troubleshooting step to help narrow down the possible cause of your problem, so let me know how you go.

  • Awarding bounty - will walk through the steps shortly when I have a few minutes. Thank you! – Luke Williams Sep 11 '17 at 14:50
  • Thanks, problem solved - it was a Login item as you noted. I have a Keyboard Maestro macro to disable/enable F keys when I switch to/from my programming environment (VS Code). Problem was, it was running on any application switch, so switching to/away from Preferences . I changed so it only runs when VS Code activates or deactivates. Thanks again for the help! – Luke Williams Sep 13 '17 at 21:31
0

There will be some debugging involved here.

The following 2 facts give the suggestion that the problem is located in your ~/Library/Preferences folder, and is likely a .plist file.

  1. The problem migrated from El Capitan to Sierra
  2. The problem is connected to your user profile

You might try to move the ~/Library/Preferences elsewhere. It is likely this will solve your problem, but this will give lots of new annoyance as well (preferences from any app will be gone). You want to search for the culprit .plist file.

I would start doing the following:

  1. Open ~/Library/Preferences, press cmd2 (list view) and order by date modified.
  2. Then I would change some keyboard settings and simultaneously look at the recently modified plist files
  3. You will notice that ~/Library/Preferences/com.apple.systempreferences.plist changes, among some other files.

I would then move these .plist files to the desktop, log out and log back in.

  • Tried this - thank you. Wasn't able to fix this way though. – Luke Williams Sep 13 '17 at 20:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .