5

This becomes a more relevant problem with the new Siri watch face. I ended up deleting most birthdays in Contacts to stop birthdays from clustering my Apple Watch screen daily.

I tried the below but failed to achieve my goals:

  • In the watch app on iPhone, go to calendar and mirror my iPhone's setting. I also make sure birthday is unchecked on the calendar settings of my iPhone. I confirmed this by going to my calendar on iphone to see no birthdays are showing.
  • I then checked my watch, the birthday is still showing in calendar. I gave ample amount of time (15mins) for the Apple Watch to sync. Look again - the birthdays are still there.
  • I then restarted my Watch - the birthdays are still there.
  • I double checked my calendar app on iPhone, no birthdays are shown and the birthday calendar is still unchecked. The calendar setting in the watch app is still set at mirror iPhone.

Then I tried with using custom instead of mirror iPhone in the watch app->calendar:

  • Uncheck the Birthday calendar

  • The birthdays are still showing on watch

  • Wait 15mins - the birthdays are still here

So I ended up deleting most birthdays in Contacts and the birthdays stop showing on my watch instantly - except those birthdays I have kept.

5
  • Is the calendar or contacts logo shown in the card? If it's the latter, then it would be logical to disable them from Watch app -> My Faces -> Siri -> Data Sources -> Contacts but it doesn't exist. – onik Oct 6 '17 at 10:12
  • Not sure if I am following you but eventually the watch died (for some other reasons) and this is not happening on the replacement watch. – Victor Yip Oct 13 '17 at 14:50
  • You said it’s not happening on the new watch. Did you restore or change your phone in the mean time? I’m trying to debug the same problem. – Hot.PxL Mar 31 '18 at 3:00
  • Yes I upgrade to 8. The watch could never be paired again. Apple took the old watch and sent me a replacement. – Victor Yip Apr 8 '18 at 1:13
  • I'm having this problem. Would be great to know if someone finds a solution. – P A N May 25 '18 at 19:04
2

Contacts.app in macOS 11 Big Sur (and the underlaying iCloud) now offers more differentiated date fields which address use cases like yours and more.

Preparation:

  1. Open Contacts.app > Preferences > Template.
  2. Add fields > Dates: Birthday or custom (depending on what's in your template already)
  • Locate the date section in the template.
  • Leave the original "birthday" field.
  • Add a custom field "birth-day" or similarly odd spelled to never collide or get confused with the real "birthday" field.
  • You may also add "date-of-death" if you want to document your deceased contacts.

Then for any contact do the following:

  • Fill the real "birthday" field if you want the person to show up in the dedicated "Birthday Calendar".
  • Fill "birth-day" (your custom date field) if you want to have that documented for a contact but not show up in the dedicated "Birthday Calendar".
  • This should also propagate to your Apple Watch then eventually.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .