My development server is Server.app. After having to reinstall macOS in recovery mode, browsers can no longer connect to my local sites. I can't select the text of the error that Safari gves so here's a screenshot... Safari Can't Connect to the Server

Other browsers give errors of the same substance.

Update: Looking elsewhere I found mention of Stealth Mode. On checking I found that was switched on during the reinstall. Turning it off now allows me to ping & my local host names in Terminal, but I still can't reach my local hosts in a browser.

The Server.app webserver is on, & all my sites are still there. I've checked the configuration of the ones that matter most right now & they're still correct. My hosts file is still as it should be.

Update 2: Expanding as a result of answer by Tom E, what I get when running the command suggested is...

Europa:~ pedro$ host volhq.mmf.yii.dev
volhq.mmf.yii.dev has address
volhq.mmf.yii.dev mail is handled by 10 your-dns-needs-immediate-attention.dev.

I have always used a hosts file rather than DNS, taking the former to be simpler & sufficient for my needs, & that has worked until now. However if setting up a DNS is the medicine, I shall take it.

Update 3: I think the question now becomes, how do I get the IP address on my host names from back to For more than 10 years I have used a hosts file with entries like volhq.mmf.yii.dev & it has worked.


Stealth Mode is a feature of the built-in firewall. If enabled, it simply keeps the firewall from responding to ”ICMP echo requests“ (aka Pings). It doesn’t keep browsers from connecting to a web server.

In your case, the reason could be a problem with your DNS configuration. Please check both the client’s and the server’s DNS setup. Try to resolve volhq.mmf.yii.dev from the client’s command line:

host volhq.mmf.yii.dev

and see what reply the command gives you. Get back here if you don’t receive an error…

|improve this answer|||||
  • This is most helpful. I've put the result in an edit to the question. – Pedro Aug 29 '17 at 12:19
  • Ok, there’s the problem. Any IP address starting with 127.0 refers to localhost. This does not make sense to any hosts except to your server itself. I’m afraid you’ll have to go through the process of setting up a clean DNS service on the server and make the clients look it up. You don’t need a lot more than an A record mapping volhq.mmf.yii.dev to your server’s real IP address. The server.app calls it a “Computer record.” – Tom E Aug 29 '17 at 12:28
  • 1
    The bit continued to bug me. Eventually I came across this stackoverflow.com/questions/25662590/… from which I take that .dev is now a TLD & I (along with many other developers) need to start using something else instead. – Pedro Sep 1 '17 at 1:20
  • You could still make your own internal domain name point to whatever IP address you want—as long as you do not need to reach any of your network components from outside. – Tom E Sep 1 '17 at 6:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .