2

I've had some problems recently with my Macbook on OSX (newest Macbook version with touch bar). Where my Touch ID used to work, suddenly, one day two things happened:

  1. My computer have started to start much slower (2-3minutes+)
  2. Touch Id does not work before

I've tried to go into Touch Id under "System Preferances". I've removed the existing fingerprint. When I click "Add a fingerprint", enter the password, it goes directly to "Failed - Unable to complete Touch ID setup".

2

Do you have synmatec or any antivirus installed? If so, uninstall them and restart your system, then try again.

0

I ended up solving this problem by simply doing a hard reinstall of everything. I haven't had this problem now since September.

After spending hours(!) on the phone with the Apple support, I simply ended up with a full re-install. That included starting OSX up in the recovery mode, full format and downloading a new version of the OSX operating system.

Not a very elegant solution, but at least my computer has been without problems since.

0

I solved this issue like described here: https://apple.stackexchange.com/a/384410

TL;DR:

Opened a Terminal and run:

diskutil apfs list

This showed a volume described as "VM" with an error -69461

Then run (replace disk1s4_changeme with your VM volume):

diskutil apfs eraseVolume disk1s4_changeme -name VM

Check that the Volume war recreated and the error is gone:

diskutil apfs list

Then set the role to VM again (the "V" has to be uppercase!):

diskutil apfs chrole disk1s4_changeme V 

Check the list output:

diskutil apfs list

You should see something like

APFS Volume Disk (Role):   disk1s4 (VM)

That's it. Now the Touch ID worked for me again! Thanks to Henrik N

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .