0

I have a USB3 drive with 128GB of storage. It has been working normally up until this evening, when I tried to right click > eject the drive. I received the following message:

“Mymusic” is a partition on a disk that has 2 partitions. Do you want to eject “Mymusic” only, or both partitions?

When I open Disk Utility, it only shows the one single partition listed under the drive. I ran First Aid on the drive itself, and it reported no problems. However, when I tried running First Aid on the partition, it failed because it could not eject the drive.

If I click on the drive in the list, and click Partition, it shows a pie chart and 100% of the drive is shown in blue, as one big partition taking up 100% of the disk. The only thing that looks weird is maybe "Child Count: 3".

Lastly, and perhaps most importantly, when I finally clicked "Close All [volumes]", I got this message:

The disk "Boot OSX" wasn't ejected because one or more programs may be using it.

Hitting "retry" continues to fail.

The disk has been formatted several times, and the most recent format was about a week ago. It has only ever had one partition (at least, that I added myself; and no one else has physical access to it). I certainly never added a partition named "Boot OSX". Maybe some malware or something? But I don't pirate software and am privy to attachments, security, etc.

Here are a couple of screenshots, in case they help:

Disk Utility 1 Disk Utility 2

I'm not sure how this can happen. How can I fix this?

1

This EFI partition is discussed at : https://discussions.apple.com/thread/4326715?start=0&tstart=0 The opinion there is that it is created by (some versions of) Time Machine. Disk Utility hides it by default, but see https://www.mede8erforum.com/index.php?topic=14019.0 for how to show it and remove it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .