It worked before, and I'm not sure when it stopped working, but I'm unable to start Web Sharing at the moment. Attempting to start it from the Sharing screen results in "Web Sharing Starting..." immediately followed by "Web Sharing: Off". I've tried reverting to the httpd.conf in /etc/apache2/original, but the result is the same.

What else could I try?

  • The apache logs are in /var/log/apache2. If the problem is not solved by @Satreix answer below please have a look at error_log and post any error message you get.
    – nohillside
    Commented Oct 30, 2011 at 8:01
  • 1
    The logs should also be easily viewable in Console.app. /Applications/Utilities/Console.app Commented Nov 29, 2011 at 7:20

4 Answers 4


First, take the time to check your httpd.conf with:

sudo apachectl configtest

If it's all ok, then try to restart Apach once or twice (look at the log):

sudo apachectl start (or restart)

It worked for me. If it still doesn't start try finding another default httpd.conf


In /usr/lib there is a file libpq.5.3.dylib while apache looks for libpq.5.dylib.

After I copied the file and named it libpq.5.dylib it worked.


There are a couple of solutions in the Apple Support Forums. I remember having the same problems and I think the module was the problem.


Run this Terminal command to symlink the different versions of libpq:

sudo ln -s /usr/lib/libpq.5.3.dylib /usr/lib/libpq.5.dylib

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .