0

I bought a 2017 iMac, migrated the contents of my 2012 iMac (so I have my data! ) and I wanted to erase the 2012 iMac it replaces using Disk Utility in Recovery Mode.

I had hoped this would be a minor step and after that I could sell my old iMac to partly fund the new one. But when starting the erase the computer got stuck. Because it got stuck I forced a shutdown with the power button.

(The drive is a 1 TB Fusion Drive. In hindsight I think it might have been best to decrypt the FileVault 2 drive before erasing it)

Now the computer starts up with a grey screen where I can type in my password. I think this screen is to unlock the FileVault encryption. But after doing that I get the black progress bar for a few mm. And then lines of bootloader/unix text presented over this grey screen and the iMac resets to the same loop.

I've tried a lot;

  • Starting in Recovery Mode; both local and through internet but text-lines and reboot again before it works
  • Starting in single user/verbose mode; doesn't work
  • Creating an external setup and installation USB to boot from that; can select it after press and hold of the option key at bootup but again lines of text and reboot
  • Getting a Thunderbolt 2 cable from a friend to connect my MacBook Pro 2013 in Target Disk Mode with Thunderbolt 2 (iMac2017 is Thunderbolt 3/usb-c) and try to boot from the MacBook Pro. Can select this as well but it doesn't work.
  • Reversed the Target Disk Mode and booted the MacBook Pro from the Fusion Drive which gave the same type of errors on the display of the MacBook Pro.
  • Tried Disk Utility on MacBook Pro and then mounting iMac-drive on that through Target Disk Mode but the MacBook Pro then resets and tries to boot from the iMac drive.
  • Whatever I do; when I attach the iMac in Target Disk Mode with the Thunderbolt cable to the MacBook Pro, even if it's in Single User Mode, it switches to booting from the iMac drive (or at least it tries to)
  • The fact that the MacBook Pro booting from the iMac drive returns the same problems seems to exclude iMac hardware errors but I ran Apple's Hardware Test anyway (D at startup). No errors found.
  • I attached the external display back which is attached by a Mini DisplayPort to DVI connector. Sometimes in the past the hardware seemed to get a bit confused when I had this screen detached. Attaching would help. Now it doesn't
  • And of course I have tried resetting NVRAM and SMC by way of cmd-option-P-R and unplugging for min. 15 seconds.

One of the lines at startup says:

CoreStorage: fsck_cs has finished for group "..." with status 0x00 panic (cpu 2 caller 0xffffff00029fe39d): Kernel trap at 0x..., type 14=page fault, registers:

Any clues to how I could fix this? The iMac 2012 is the first one with the glued screen glass so opening it up to remove the drives would be the absolute last resort!

Hope someone knows of an external fix!

Update: through Shift-Option-Command-R I was able to start (Mountain Lion?) recovery and Disk Utility. It sees the Macintosh HD but repairing it doesn't work.

Blocks on device .... are not accounted for by CoreStorage Unable to bootstrap transaction group ...." inconsistent crosscheck no valid commit checkpoint found The volume...is found to be corrupt and needs to be repaired.

1

I was able to solve it using shift-cmd-option-R. I tried internet recovery before and it didn't work but the adding of the shift key installs the recovery version of the original OS the computer was on when new. That way I was able to start terminal and wipe/fix the drives! I am now installing Mountain Lion from this recovery and then back to Sierra.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .