2

I am on a MacBook Pro 13 running latest Sierra. I have an external Seagate solid state hard drive that was working and out of the blue stopped working. The only thing on it was my Adobe Lightroom images/videos. Not the LR DB files. I'm sure you have all heard this woe before, so I won't dwell on that. And yes, I back up to the cloud. AWS S3 specifically. Though I am traveling South East Asia for the last year, and staying in cheap hostels. So good internet is hard to come by sometimes. I can't back it up after every export. While most of it is backed up, there is some that is not.

Moving on. The symptoms seems to change every time I plug it in. The first sign was it ejected on it's own. I plugged it in again, and it wouldn't mount. Disk Utility recognized it, so did the command line diskutil list but it wouldn't mount. I rebooted and it worked for a second. Then I could only get to it from the command line. Then trying to frantically back up to my local what was not backed up to the cloud, it all failed. Basically just a cp -R [directory] [local-directory] command.

After some more frantic unplugging and re-plugging plus some command line manual mounts, I finally got it to where the Disk Utility would be able to run first aid on it. It failed. I don't recall the error. So I put it in a freezer. After a few hours I tried again. It is not any better. It still will not mount. Now Disk Utility sees it, but with no partition. I can't even give me information about how much space is used on it.

I have also tried it from a Windows machine. It did not mount. I have tried other cables. No success. As well as tried my other USB port. I also have another working external hard drive exactly like the one giving me issues. It works on all cables and USB ports.

I do have Docker running with a Ubuntu container, I'm trying to think of a way to see if I can try to get to the USB from there. I also have a USB that I have thought about running a live Ubuntu on there to see if I can mount and retrieve the data or fix the HDD that way. But if it will not mount, I doubt these will work.

Can anyone else think of any other tricks I can try myself to see if I can repair this or at least retrieve the data without paying for a service or software? If not, those suggestions are also welcome.

Update

  • I made the mistake in original post that it was a Solid State Drive. This is my mistake, it is actually a spinning disk hard drive. I bought them long ago and have been traveling with them for so long I just forgot. Question is updated to reflect this.
  • Now diskutil list does not show it at all. The Disk Utility app also does not see it.
  • Based on suggestion from @Allen I seeked out the USB to SATA cable. I did not quite find it, as my options are extremely limited where I am at. Though a local expat on a facebook group was able to help me with a empty 2.5 casing that I was able to extract the drive from original casing and put it in his blank case. It now mounts. Though it has the "click of death" sound to it. And data is not really reachable. While I can ls the directories and Adobe Lightroom does not have the exclamation mark when it can not reach the actual external files. Right clicking on the images and clicking on "Show in Finder" or any other variation of trying to get to the files through Finder or terminal, I have no success. It usually hangs and I get the spinning wheel. Since Adobe Lightroom imports these images into directories named by date, I am going to send the drive off to a data recovery service and ask to recover just unbacked up directories i.e. dates. Next time I will make harder efforts to backup and probably get an actual SSD.

I think this can be closed, due to my low reputation points I can not close this myself.

  • 2
    What's the purpose of putting an external SSD into a freezer? Condense/deposite some air humidity to lubricate/snow-cover the flash memory cells? "I don't recall the error.": The error message is required, so open Terminal, enter diskutil list and with the device identifier of the external disk diskutil verifyDisk diskX. Then - if possible - verify the main volume: diskutil verifyVolume diskXsY (probably disk2s2). – klanomath Aug 25 '17 at 15:02
  • @klanomath diskutil list only shows my laptops hard drive and nothing more. I can not run diskutil verifyVolume of diskutil verifyDisk because it does not see it at all. – Byron Mansfield Aug 26 '17 at 12:16
1

...any other tricks I can try myself to see if I can repair this or at least retrieve the data without paying for a service or software?

Based on everything you said, there are only two conditions that exist:

  • The USB enclosure has failed. This is the least bad scenario. The "enclosure" has a USB to SATA controller that is the interface of the drive. It's not out of the realm of possibility that it "reports" back the drive, but refuses to mount/read/write/etc.

  • The SSD drive itself has failed This is the worst case scenario. If the drive has failed, there's nothing you're going to do to force it to start working.

How can you find out which scenario is the one you're dealing with? I wrote an answer to a similar question that addresses this situation exactly. It involves a cheap USB to SATA adapter to remove the enclosure from the equation. If the drive works, it was the enclosure; you get the added benefit of the adapter being a temp solution until you get the enclosure fixed (or another external drive). If it doesn't work, then you know the SSD has died.

  • In addition to the possibility of the enclosure or drive being bad, you should also check the cable and port on your computer to make sure they are not the problem. – user128998 Aug 26 '17 at 12:35
  • Thank you, this was very helpful. It gives me hope. I will hunt around for this cable. Since you have mentioned it, I do suspect that it could be the electricity here. From my reading it's commonly 220-240 volts in most places around SEA. Also, I can literally feel it from the surface of my macbook when I plug it in. Then I unplug it and it stops. These external drives are not self powered, but powered by the laptop. I am not sure if this makes them more or less vulnerable. But whatever electronics inside these tiny hard drives can't be much to protect them against these voltages. – Byron Mansfield Aug 26 '17 at 12:36
  • @user128998 Thank you for pointing this out. I did try this, I will update my original post to make sure it is included. – Byron Mansfield Aug 26 '17 at 12:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .