3

I currently own a 32 GB SanDisk flash drive with a FAT32 file system. It's been reliable for years, and on my MacBook Air 2013, I've never had any issues with it. However, I am unable to connect it to my MacBook Pro 2016 with Touch Bar running macOS 10.12.6. After some further investigation, I found that the FAT32 file system seems to be causing the issue, considering that ExFat-formatted flash drives successfully appear in Finder while my own FAT32 drive does not.

I could reformat my flash drive to an ExFat file system, but before I do so, I'd like to know if it's possible to mount FAT32 drives on my MacBook Pro, since I cannot realistically reformat every flash drive that I'd ever like to plug in in the future (whether it be someone else's drive that I'm using to exchange files with them, or their Samsung phone, whose file system seems to be incompatible with Apple's new APFS). I've tried installing Fuse, but have not yet had any luck with it. I've also found a Fuse FAT32 file system extension, but am unsure of how to install it.

With all of this in mind, how would I connect my FAT32-based flash drive to my MacBook Pro without reformatting the drive?

  • 1
    There ought to be no inherent issue with Mac & FAT32. Did you check that particular card in other machines? – Tetsujin Aug 24 '17 at 20:02
  • @Tetsujin Yes, I did. It worked on my old MacBook Air, which is running an earlier version of macOS (I think pre-Sierra), as well as a PC. I think the issue is being caused by Apple's new APFS file system, which was introduced in 10.12.6, so I assume that only ExFat-formatted drives now work with my computer... unless I can find a way around that. – jmindel Aug 24 '17 at 20:19
  • 1
    APFS is only available in MacOS High Sierra (10.13) Not on any earlier version of macOS. It is more likely that there is an issue with the file system on the USB drive. I would back it up, reformat it as exFAT and try again. It is also possible that something in the USB drive's hardware is failing. You could also try putting the drive into another port. I find that works often times for me. – Steve Chambers Aug 25 '17 at 0:46
  • 1
    Actually, I got the exact same issue... let us know as an answer if anyone has a solution for this. Nda - my hard-drive was formatted on a Linux system and I had no issues reading from it, also previously readable on MacBook 2013 – aechchiki Aug 29 '17 at 22:51

You must log in to answer this question.

Browse other questions tagged .