1

I don't deleted the files, my External USB Hard Disk is not broken, it not suffered fall.

enter image description here enter image description here

On the second image you can check the size of the HD 1TB with 2nd partition Size of 999.9GB, but on the first you can see 649.69GB.

When I select with Finder the HD, become to very slow. The Finder can't to move to another location appears the colored wheel. And I need to turn off my MacBook Air and to start again.

verifyVolume first

$ diskutil verifyVolume /dev/disk2s2
Started file system verification on disk2s2 ADATAHD
Verifying file system
Checking Journaled HFS Plus volume
Checking extents overflow file
Checking catalog file
Checking multi-linked files
Checking catalog hierarchy
Checking extended attributes file
The volume ADATAHD could not be verified completely
File system check exit code is 8
Error: -69845: File system verify or repair failed
Underlying error: 8: Exec format error
$

repairVolume command

$ diskutil repairVolume /dev/disk2s2
Started file system repair on disk2s2
Repairing file system
File system check exit code is 8
Updating boot support partitions for the volume as required
Error: -69610: Error parsing fsck program XML format output
Underlying error: 8: Exec format error
$ 

Using fsck_hfs command

$ sudo fsck_hfs -fryd /dev/disk2s2
Password:
journal_replay(/dev/disk2s2) returned 16
** /dev/rdisk2s2
    Using cacheBlockSize=32K cacheTotalBlock=32768 cacheSize=1048576K.
   Executing fsck_hfs (version hfs-366.70.1).
    could not get volume block 2, err 16 
    could not get alternate volume header at 1952853342, err 16 
volumeType is 0
0000:  00e0 0910 0100 0000 0000 0000 0000 0000       |................|
0010:  0000 0000 0000 0000 0000 0000 0000 0000       |................|
. . .
01f0:  0000 0000 0000 0000 0000 0000 0000 0000       |................|
    unknown volume type 
    primary MDB is at block 0 0x00 
    alternate MDB is at block 0 0x00 
    primary VHB is at block 0 0x00 
    alternate VHB is at block 0 0x00 
    sector size = 512 0x200 
    VolumeObject flags = 0x01 
    total sectors for volume = 1952853344 0x74662d60 
    total sectors for embedded volume = 0 0x00 
    CheckForClean - unknown volume type 
    CheckHFS returned 6, fsmodified = 0
$

check the info

$ diskutil info /dev/disk2s2
   Device Identifier:        disk2s2
   Device Node:              /dev/disk2s2
   Whole:                    No
   Part of Whole:            disk2

   Volume Name:              ADATAHD
   Mounted:                  Yes
   Mount Point:              /Volumes/ADATAHD

   Partition Type:           Apple_HFS
   File System Personality:  Journaled HFS+
   Type (Bundle):            hfs
   Name (User Visible):      Mac OS Extended (Journaled)
   Journal:                  Journal size 81920 KB at offset 0x3410001000
   Owners:                   Disabled

   OS Can Be Installed:      No


   Media Type:               Generic
   Protocol:                 USB
   SMART Status:             Not Supported
   Volume UUID:              3A0FE0A0-1B83-3142-BC3A-97690E712867
   Disk / Partition UUID:    8B32B8BE-35B8-41B8-B5D5-E219EEBBD14D

   Disk Size:                999.9 GB (999860912128 Bytes) (exactly 1952853344 512-Byte-Units)
   Device Block Size:        512 Bytes

   Volume Total Space:       999.9 GB (999860912128 Bytes) (exactly 1952853344 512-Byte-Units)
   Volume Used Space:        349.4 GB (349353291776 Bytes) (exactly 682330648 512-Byte-Units) (34.9%)
   Volume Available Space:   650.5 GB (650507620352 Bytes) (exactly 1270522696 512-Byte-Units) (65.1%)
   Allocation Block Size:    4096 Bytes

   Read-Only Media:          No
   Read-Only Volume:         No

   Device Location:          External
   Removable Media:          Fixed


$

Now I was trying this with gpt:

$ sudo gpt -r show disk0
Password:
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  235298960      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC
  235708600    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  236978136          7         
  236978143         32         Sec GPT table
  236978175          1         Sec GPT header
$ sudo gpt -r show disk1
gpt show: unable to open device 'disk1': Resource busy
$ sudo gpt -r show disk2
gpt show: unable to open device 'disk2': Resource busy
$

using repairDisk

$ diskutil repairDisk disk2
Repairing the partition map might erase disk2s1, proceed? (y/N) y
Started partition map repair on disk2
Checking prerequisites
Problems were encountered during repair of the partition map
Error: -69808: Some information was unavailable during an internal lookup
$ 

Is different the numeration for hard disks?

I’d like to see if fsck fixes the drive but get an error:

$ sudo fsck -f -l /dev/disk2s2
Password:
fsck: -l flag requires a number

What arguments needs l option?

  • 1
    Can you give some more details? Is your drive broken? What have your tried? Have you accidentally deleted the files? What is in the .Trashes directory? What does Disk Utility say when you want to repair the disk? – CousinCocaine Aug 24 '17 at 9:36
  • I’ve reopened this and will edit it down to one question. Let’s focus on the fsck - keep in mind that fsck will delete files and return the filesystem to a consistent state - so if you want to recover missing files Chepe- don’t run fsck and instead get recovery software first. Any changes you make can result in permanent data loss at this point. – bmike Aug 24 '17 at 17:28
  • For fixing the filesystem - something like this might work. For file recovery - look for commercial software recovery tools. You get what you pay for there - usually $50 for USB drive recovery software is appropriate. – bmike Aug 24 '17 at 17:31
  • @bmike But I can't found the recommended software, I tried with gpt (gpart for mac) but doesn't work. – Chepe Questn Aug 26 '17 at 15:02
  • Try something like DiskDrill. The free version will let you know if you can recover your files. – Allan Aug 28 '17 at 3:00

You must log in to answer this question.

Browse other questions tagged .