1

I have a 3G iPad 2 running iOS 4.3.5. I wanted to jailbreak it but most articles point to 4.3.3 and the downgrade isn't applicable to my model .

I wanted to know if it is possible to jailbreak my device?

1

They point to 4.3.3 because that's the last version that supported an untethered jailbreak. Any version after 4.3.3 cannot be jailbroken: http://theiphonewiki.com/wiki/index.php?title=Jailbreak

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .