0

I'm running macOS 10.13 High Sierra on my 2011 15" MacBook Pro. Whenever I try to enable Location Services, the checkbox momentarily turns 'checked' and then goes back to disabled.

System Preferences - Security & Privacy

How can I enable Location Services on this Mac? Is it not an option because the Bluetooth is limited to v2.1?

1

This script worked for me, macOS Sierra.

More details pls check here: https://www.jamf.com/jamf-nation/discussions/22095/enable-location-services-after-imaging

#!/bin/bash

## Unload locationd
launchctl unload /System/Library/LaunchDaemons/com.apple.locationd.plist

## Write enabled value to locationd plist
defaults write /var/db/locationd/Library/Preferences/ByHost/com.apple.locationd LocationServicesEnabled -int 1

## Fix Permissions for the locationd folder
chown -R _locationd:_locationd /var/db/locationd

## Reload locationd
launchctl load /System/Library/LaunchDaemons/com.apple.locationd.plist

exit 0
0

Not 100% sure what was causing everything, but I did a full reinstall of macOS and it solved the issue. Probably a corrupted system file or plist.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .