3

Macbook Pro 2011 A1278 13" OS X 10.9.5

I cannot connect to Wi-Fi, the Wi-Fi symbol in the top right has a cross through it and when i click it says "Wi-Fi: No hardware installed". I've tried connecting to the internet via ethernet, when I plug in the ethernet cable it says connected under "network" but the internet doesn't work - pages won't load in safari, app store won't connect etc.

I've tried resetting the NVRAM and SMC.

Thanks.

Update: The wi-fi problem was fixed by replacing the cable between the airport card and the motherboard. The ethernet was fixed by deleting the connection under system preferences > network and adding it again.

0

The error message that macOS/OS X supplies is the key:

the Wi-Fi symbol in the top right has a cross through it and when i click it says "Wi-Fi: No hardware installed"

It simply cannot find it to configure it. Unfortunately, there's not a VRAM or setting file that will fix a failed board. An SMC reset won't have any effect because it's connected via the PCI bus which means if the SMC was failing, pretty much everything else on your MBP would be failing; the SMC controls power delivery to the whole PCI bus, not just individual parts.

The good news is that its fairly inexpensive and something you can repair yourself (Apple PN# 661-5867)

enter image description here

Ifixit.com has an excellent step-by-step tutorial with pictures that walk you through the replacement. They even sell the plastic spudger tools shown in the example. With a little patience and time, you can fix this without having to incur massive costs from a repair shop.

As for your Ethernet, that's technically a completely different issue; it's different hardware altogether but still part of the PCI bus (this is why SMC reset has no effect). When the OS reports back that it's "connected" it's saying that it has "found and made a connection."

To verify this, type ifconfig en0 and you should get something similar to this (your's will have different values):

en0: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
        options=10b<RXCSUM,TXCSUM,VLAN_HWTAGGING,AV>
        ether a8:20:44:18:3b:2d 
        inet 192.168.1.13 netmask 0xffffff00 broadcast 192.168.1.255
        nd6 options=1<PERFORMNUD>
        media: autoselect (1000baseT <full-duplex,flow-control,energy-efficient-ethernet>)
        status: active

The important value here is inet. If you don't get a valid IP address, it just means that DHCP didn't assign you one. A reboot will usually fix the issue.

  • I thought this might be the case, however the bluetooth works fine. If the airport card had failed, wouldn't it be the case that bluetooth would also not work? – RBaker Aug 21 '17 at 12:07
  • Not necessarily. The wireless "chip" may be fine, it may just be a simple component on the wireless card PCB that died - it could be a $0.02 resistor or diode that gave up the ghost. Her's a pic of the back of the PCB. Any of those components could have failed. – Allan Aug 21 '17 at 12:13
  • Interesting, thanks for your help, I'll give this a go. – RBaker Aug 21 '17 at 12:16
  • Update: I ordered a new airport card, while waiting for it in the mail, I figured I would try unplugging and plugging back in the cable between the airport card and the motherboard in case it was simply a loose connection. However, when unplugging the cable from the motherboard, the cable separated from the plug and the plug stayed in the motherboard, after removing the plug from the motherboard I ordered a new cable. After replacing just the cable the wi-fi works fine! Thanks for your help in tracking down the problem. – RBaker Aug 28 '17 at 3:58
  • Also, the ethernet is now working after removing the connection from network manager and reconfiguring it. – RBaker Aug 28 '17 at 4:07
0

The first thing I would try is removing your Wi-Fi service, restarting your MBP, and then adding your Wi-Fi service back.

Follow these steps:

  1. Go to Apple > System Preferences > Network
  2. Select the Wi-Fi service on the left-hand side
  3. Click on the cog icon at bottom-left and select Make Service Inactive
  4. Now delete the service by clicking on the minus sign (i.e. the - button) at left of the cog
  5. Click on the Apply button
  6. Exit Network preferences
  7. Restart your MBP
  8. Go to Apple > System Preferences > Network
  9. Click on the plus sign (i.e. the + button) at left of the cog
  10. In the pop-up window, ensure that Wi-Fi is selected from the drop-down menu
  11. Click on the Create button
  12. Make sure Wi-Fi is on and connected (it should remember your previous settings, but if not just re-add your Wi-Fi network again)

If this doesn't work you can test to see what happens in Safe Mode.

Boot into Safe Mode

  1. Fully shut down your MBP
  2. Restart your MBP
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Test to see what happens (i.e. try connecting to Wi-Fi)
  6. Exit Safe Mode by restarting your MBP as normal
  7. Test again to see what happens

Note: Booting into Safe Mode will take longer than usual.

If you're still having problems during Safe Mode, then try testing your hardware.

Run Apple Hardware Test

Your model MBP uses Apple Hardware Test. To use this, follow these steps:

  1. Shut down your MacBook Pro
  2. Restart your MacBook Pro
  3. Press and hold the D key before the gray startup screen appears.
  4. After a while, Apple Hardware Test (AHT) will start.
  5. When prompted, select your language and click the right arrow.
  6. When the AHT console appears, you can choose to run Basic tests by clicking the Test button. However, I suggest you select the "Perform extended testing" checkbox before you click the Test button.
  7. Your test results will appear in the window in the bottom-right of the console.

Note 1: The extended test will take some time. Take a note of the results and report back.

Note 2: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

Run these Terminal commands

Let's confirm what macOS believes the status of your Wi-Fi service is. To do this:

  1. Launch Terminal (usually found in Applications > Utilities)
  2. Enter the following command:

    sudo networksetup -listallnetworkservices

  3. Press Enter

  4. Enter your password (note you will not see the cursor move, nor the characters appear on the screen)

Now, in the list that appears I assume you will see an asterisk (*) next to the Wi-Fi service. This denotes that it is currently disabled. Assuming this is what happens, let's try enabling it as follows:

  1. Make sure you're still in Terminal
  2. Enter the following command:

    networksetup -setnetworkserviceenabled Wi-Fi on

  3. A popup will prompt you for your password - enter it and click on the Modify Configuration button

  4. Now enter this command:

    networksetup -setairportpower en0 on

  5. Restart your Mac

  6. Now check System Preferences > Network again

Let me know how you go.

  • When going through your instructions, when I get to the 10th bullet point there is no Wi-Fi option in the drop down menu, only Thunderbolt Bridge, Thunderbolt 1, Bluetooth PAN, FireWire, Ethernet, Bluetooth DUN, VPN, PPPoE, and 6 to 4. – RBaker Aug 21 '17 at 10:42
  • Okay, I've added some terminal commands you can try as well. – Monomeeth Aug 21 '17 at 10:50
  • When I run sudo networksetup -listallnetworkservices it lists Bluetooth DUN, ethernet and Wi-Fi but there is no asterisk next to Wi-Fi – RBaker Aug 21 '17 at 11:13
  • some additional info - when I go into system preferences > Network, it lists Wi-Fi Off, when I click Turn Wi-Fi on, the status remains off. – RBaker Aug 21 '17 at 11:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .