1

When I mute a group conversation in Messages (by enabling “Do Not Disturb” in the Details screen of the thread), I still get a notification with every new message. This happens regardless of whether everyone in the group is using an iPhone or mixed (non-iOS and iOS). This also happens when my phone is both locked and unlocked.

I am running iOS 10.3.3, but it's been happening for some time. Is there a workaround to fix this?

2

This is how Do Not Disturb was designed for text conversations. This feature blocks sound notifications and that’s it.

In fact, it works the same way the global Do Not Disturb works, with one major difference: going into Settings → Do Not Disturb and setting Silence to Always does NOT block banners or alerts for muted threads. The only way to disable those is by disabling them for ALL incoming text messages, or by activating the global Do Not Disturb.

If you are displeased with Apple’s implementation of this feature and believe it should work differently, I strongly advise you to voice your feedback to Apple.

Many people would agree with you, as a quick search will reveal.

  • Do Not Disturb in iMessage doesn't even block sound for me. it's like it's not even working. – RHPT Aug 22 '17 at 23:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .