2

Every single time I open an email to address to my mom, I see this, and absolutely nothing I've tried will get rid of it:

enter image description here

This is absolutely ridiculous. I don't want to see porn spam in my auto complete addresses! There has GOT to be a way to turn this off!

I've gone so far as to search for and eliminate every trace of every email originating from that address in my inbox, junk and trash, quit and restarted Mail and it's still there.

Update: It looks like I may have finally solved this by some obscure post I found on the web. In short, I had to open the Contacts app and disable "Show contacts found in Apps". It seems there was some kind of heinous loop happening here: Contacts was automatically finding contacts based on the emails I received, and Mail was apparently using my Contacts to auto-fill that address, but there was no setting anywhere in Mail to control this!

  • Try this: lifewire.com/delete-address-from-auto-complete-1172745 – user161254 Aug 18 '17 at 21:20
  • @raaowx I tried that too, but it doesn't appear as a "previous recipient" because I've never sent an email to that address! It also doesn't appear anywhere in the previous recipients list. – devios1 Aug 18 '17 at 21:21
  • 1
    @devios1 If that is indeed the solution you should post it separately as an Answer and accept it. – user11633 Aug 19 '17 at 3:27
2

One possible option is to delete the file that stores all that data. That file is stored on:

/Users/YOUR_USERNAME/Library/Application Support/AddressBook/

There is a file called: MailRecents-v4.abcdmr

Seems like that file stores all the autocomplete address.

If you delete that file you will lose all others previous recipents address. So I'll follow the following steps:

  1. In Mail.app: Menu Window > Previous Recipents. There copy all address that you don't have stored in your contacts and you want to keep
  2. Close Mail.app
  3. Backup MailRecents-v4.abcdmr file by copying it to desktop (for example)
  4. Delete all files called MailRecents-v4.abcdmr stored on /Users/YOUR_USERNAME/Library/Application Support/AddressBook/ folder. You will see another MailRecents-v4.abcdmr-* files. They store other info of the autocomplete address.
  5. Open Mail.app and try to create an email.

PS: If something goes wrong opening the Mail.app on the step 5., restore the backup files that you copy to the desktop.

  • 1
    Thanks for this. I think I may have finally solved it another way. I will update the question. – devios1 Aug 18 '17 at 21:53
  • Cool! Let us know how :D – user161254 Aug 18 '17 at 21:53
0

So what finally ended up working for me (I tried a lot of things believe me) was to follow the instructions on this web page.

In summary:

  1. Open Contacts app
  2. Open Contacts Preferences (cmd-,)
  3. Under the General tab uncheck "Show contacts found in Apps"

It seems that the Contacts app was collecting email addresses from mail I had received and automatically added implicit contacts to my address book, which Mail was sourcing for its autocomplete.

It finally seems to be gone now, but it had been that way for close to a year, believe it or not. This is just an example of some really dumb "intelligence" if you ask me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .