0

Here's a gnarly boot problem.

My older MBP (4,1) decided it wouldn't boot last week. It has been working fine for years, running trusty, dependable 10.6.8. System is a 2.5 GHz Core2 Duo with 4GB.

At start-up, it plays the chime, displays gray screen, followed by the Apple logo. Then the little gray spinner appears and goes round and round. After 10-15 seconds, the spinner freezes and the boot process goes no further.

Resetting NVRAM and SMC didn't help.

I've tried booting from a Snow Leopard DVD. The optical drive spins up and the head chatters for a couple of minutes as the CPU reads files from the DVD. Then the system crashes with the unhappy 5-language error message :

Your Mac encountered problems and needs to restart.

Tried booting from an Applecare Protection Plan CD (which contains TechTool Deluxe). I can hear it reading the CD, but after a minute or two, it goes dormant.

Next up, a USB memory stick that has an El Capitan installer on it. (I've used the stick to install El Capitan on a number of other Macs, but not this one). I get the gray screen, the Apple logo, followed by a progress bar as the MBP boots from the USB drive. The activity light on the USB stick blinks away as its files are accessed. The progress bar gets about 3/4 of the way through, then it stops. No further activity.

Next -- boot into single-user mode (Cmd-S). This works fine. Once in single-user mode, I was able to do an fsck scan of the internal drive. I could list files, repair permissions, empty caches, and various other low-level operations. But after exiting out of single-user mode, it still doesn't boot from the hard drive.

My last test was to boot from a FixMeStick. FMS is a commercial anti-virus scanner on a USB stick. I believe it's built on a Debian kernel. The FMS booted with no problems, and then proceeded to scan the entire contents of the internal HD looking for viruses. This took a few hours, which is quite normal. At the end, FMS reported no viruses found. While the MBP is unhappy with Apple boot software, it has no objections to running this particular Linux system.

The behavior when booting from the FMS system (and when in single-user mode) suggests that the MBP is fundamentally healthy: mobo OK, HD OK, HD controller OK. I haven't tried swapping the memory, but I doubt that FMS would run successfully (and for hours) if the memory was flaky.

What other troubleshooting steps could I try before consigning this MBP to the silicon graveyard?


OP with an update on my MBP boot problem:

I swapped the 2x2GB memory modules (after-market RAM) with the original 2x1GB modules that shipped with it. No change.

As discussed in the comments, I located the Apple 10.5 distro CDs that came with this early-2008 MBP. With Install Disk 1 in the optical drive, a boot-D brought up AHT. AHT appeared to test the memory successfully, but when it progressed to the Logic Board test, AHT froze with the progress bar at about 95%. The cursor was frozen, and AHT made no further progress after 10 minutes of waiting. The version of AHT that’s on the 10.5 distro is 3A152.

In order to rule out a defective Install Disk and/or faulty optical drive, I built a bootable USB stick containing AHT (using the F42C89C8 AHT module posted on the Github AHT repository). The version of AHT that gets installed on the USB stick was 3A134. When that older version of AHT runs, it quickly reports a problem: Error: 4VDC/1/40000003: video controller

Ms. Google tells me that 2008-09 vintage Macs were frequently plagued by a faulty NVIDIA GeForce 8600M video controller. Apple had an extended warranty program for the defect, which is now long since expired. Seems the chip (or its BGA contacts) in my MBP has finally failed. Oddly, the Mac has never exhibited any video problems. Nor is it now — no glitches, no funny lines, no jittering.

I find it odd that my Debian-based FixMeStick runs just fine. It has a basic GUI that displays menu bar, graphics, buttons, scrolling windows, and the like. Perhaps its video driver is less demanding of the GeForce 8600M.

It appears that this MBP has come to the end of its service life. Maybe I can find a way to install a Linux distro on it, or harvest it for parts.

  • What does Apple Hardware Test (AHT) say? Hold the D key while booting from a powered off state with the AC adapter connected. Given the age of that MBP, you may need Installation Disk 2. You can also try booting in Verbose Mode (hold Cmd-V until the boot chime). However, based on past experience, your GPU may be going south – Allan Aug 18 '17 at 18:51
  • Boot-D got the same as a normal boot: the gray spinner which froze after 20 seconds. However, your reference to Installation Disk 2 reminded me of the good ole days when OSX came on a pair of CDs. So I searched the basement and found the 10.5 installation package that came with this MBP. – kyphos Aug 19 '17 at 1:29
  • A boot-D with the Install disk in the optical drive got me to AHT. Ran it. It got through Testing Memory OK and proceeded to Testing Main Logic board. Progress bar went to 7/8 then stopped. AHT still displays "testing in progress", but after 30 min, it's dead. Cursor frozen. – kyphos Aug 19 '17 at 1:36
  • Cmd-V got a screen and a half of log messages, most of which I don't understand. The last few messages before it freezes are related to networking: Airport , and the GigE adaptor (AppleYukon2). – kyphos Aug 19 '17 at 1:47
  • Can you post a photo? – Allan Aug 19 '17 at 2:18
1

The OP answers his own question, which was "what other troubleshooting steps could I try...".

Here are the steps that led me to an unhappy conclusion.

1) Try booting while holding the D key, hoping to get into AHT. My MBP had 10.6.8 on it. That system either has no built-in diagnostics installed (the AHT software lives in /System/Library/CoreServices/.diagnostic), or the version that's there is not compatible with this MBP(4,1)

2) Try boot-D with Apple 10.6 distro DVD in the optical drive. Same finding as (1) above.

3) Try boot-D with the OSX CDs that shipped with the MBP (OSX 10.5). The Install 1 CD contains AHT software which is compatible with the MBP, and the AHT environment starts up. However, after testing the memory, AHT hangs with the progress bar at 95%, and reports no errors. The version of AHT which is on the 10.5 Install 1 CD is 3A152

4) Download an older version of AHT (3A134) from Github here: https://github.com/upekkha/AppleHardwareTest This version will boot the MBP. It tests the memory, then reports an error with the video controller: 4VDC/1/40000003

I haven't found any 'workarounds' for what appears to be a bad NVIDIA graphics chip. Ms. Google reports that some people have been able to fix this problem by baking the main logic board to reflow the BGA solder bonds to the graphics chip. (this requires total disassembly of the MacBook). Another 'fix' is to replace the main logic board. Neither seem attractive on a 9-year old computer.

However, I have found a possible path which may keep this MBP out of the landfill for a while longer. I downloaded the latest version of Linux Mint, burned a LiveCD, and booted from it. Unlike OSX, Mint starts up and runs. However, it displays a warning advising that it is using software implementation for graphics that will consume lots of CPU. I surmise that the Mint start-up code detected that the NVIDIA graphics chip was malfunctioning and bypassed it. So the MBP may live on as a headless server, running Mint or some other Linux distro.

Thanks to Allan for responding to my query and pointing me at AHT on OSX distribution disks...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .