0

This question already has an answer here:

There is only one thing I hate on macOS (Sierra) since this was created.

I open an application and work on it.

I click on another application on the dock and the whole screen slides to the right and I see that app.

I click on the first application on the dock and the whole screen slides to the left.

For heaven's sake. How do I disable this? If I want to slide I go to an ice rink.

I have already typed that on terminal and restarted the machine

defaults write com.apple.dock mcx-expose-disabled -bool true

and this hateful thing continues.

I want to disable spaces, mission control and for that matter launchpad too and all other things like that.

marked as duplicate by Tetsujin macos Aug 17 '17 at 17:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    If you want to disable Spaces, you also have to stop using fullscreen. Every fullscreen app gets its own Space. – Tetsujin Aug 17 '17 at 16:58
  • add that to my list: disable full screen apps. I hate them too. I never use them. – SpaceDog Aug 17 '17 at 16:59
  • 1
    OK, then if you don't use fullscreen you don't need to map apps to Spaces. Problem solved. Work in one Space, everything piled on top of everything else. Spaces don't populate themselves, you have to have done it. – Tetsujin Aug 17 '17 at 17:01
  • I guarantee you I am not mapping anything to any space. MacOS is doing that alone. – SpaceDog Aug 17 '17 at 17:03
  • 1
    Nope. It won't do that. – Tetsujin Aug 17 '17 at 17:03
1

If you have multiple spaces, you can delete them by exposing the Spaces (by default, Control-Up arrow), and then hover over one of the spaces with your mouse pointer. After a moment, you should see a round (X) appear in the upper left corner. Click and it will delete the space, repeat until you have only one left.

If you find that when you launch an app a space comes back, right-click on the App's icon in the dock, and look under the "Options >" menu. There may be a checkmark beside "This desktop." If so, selecting "None" and then closing the Space like before should stop that.

Edited based on comments: Mission Control does need to be re-enabled first. In the terminal, type

defaults delete com.apple.dock mcx-expose-disabled

and then

killall Dock

And wait for the dock to reload. Then, clear the unwanted spaces (or all of them!) and re-disable Mission Control.

  • these shortcuts do nothing for me. – SpaceDog Aug 17 '17 at 17:02
  • Check in System Preferences->Mission Control, and look for the "Mission Control" keyboard shortcut, there may not be one assigned. You can assign one temporarily and use it to clear out the Spaces, then unassign it. – bdonovanw Aug 17 '17 at 17:05
  • You may need to re-enable mission control first. Do: defaults delete com.apple.dock mcx-expose-disabled and restart the Dock, then go in and delete the spaces, and then disable it again. – bdonovanw Aug 17 '17 at 17:09
  • For fu*k's sake, deleting the key did mission control appear back and then I saw I had 32 spaces that I never created. I deleted all them and turned mission control off again. Now I am happy. THANKS! – SpaceDog Aug 17 '17 at 17:14
  • 1
    Absolutely :-) Glad I could help! – bdonovanw Aug 17 '17 at 17:14

Not the answer you're looking for? Browse other questions tagged .