1

One of my bread and butter jobs for clients is replacing bad/old disks in their Macs. I have a standard procedure:

  1. Install new hard disk
  2. Install latest possible OS and create account called "Admin"
  3. Using Admin, do all updates.
  4. From Admin account and using old disk as an external, use Migration Assistant.

In all the years that I've done this, I've never had a problem with the process. At the end of the process, I would see the Admin account that I created (so I didn't have to ask the client for their password) and the user's account(s). Worked like a charm, every time.

Until this one.

I did the same procedure as listed above, but at the end of the Migration process, before rebooting I see the following:

administrator password prompt

The password I used several times before the Migration isn't working. I tried several variations based on different keyboard layouts. I also booted into recovery mode and Very. Carefully. reset the password. Still no luck. I did that again and changed it to "55555" thinking that it would be very hard to mess that up or be affected by keyboard layout issues. No dice.

Last night, I started from scratch: erased the new disk, installed OS, performed updates and let the migration go during the night.

When I woke, same result.

Does anyone have any idea what this could be and what I could try?

  • To finish the job, I just erased, re-installed, manually created the user account and copied the data folder by folder, thereby losing the benefits of Migration Assistant. But at least client can log in! – Zonker.in.Geneva Aug 17 '17 at 15:55
  • I wonder if you remove the /var/db/.AppleSetupDone file in single user mode and then reboot would that let you create a new admin account with a known password that would allow you to bypass this issue? Not sure, just a thought... – Steve Chambers Aug 17 '17 at 16:07
  • good thought, thanks. I'll try that next time, but I've worked around the problem for this time. – Zonker.in.Geneva Aug 17 '17 at 16:59

You must log in to answer this question.

Browse other questions tagged .