1

This question already has an answer here:

On MacOS, El Capitan, any file I delete from Finder does not go to the Trash, it is deleted completely. When I delete a file the warning message says "you are about to permanently delete the file".

So it seems as though, the Trash has been disabled - how do I renable it?

The Mac is a Mac Mini, Core i5, 8GB RAM and 500GB SSD.

marked as duplicate by klanomath macos Aug 15 '17 at 19:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This article may help you straighten things out. – IconDaemon Aug 15 '17 at 17:16
  • Repair permissions is gone" it is now in the FirstAid button. – LexS Aug 15 '17 at 19:13
0

There are two likely possibilities:

First, you're accidentally holding down the Option key or it is stuck - do you get the same behavior if you use a different keyboard?

Second, the permissions on your ~/.Trash may have become corrupt; run Disk Utility from your /Applications/Utilities folder and verify permissions on the drive containing your home folder - if errors are reported, restart from Recovery Mode and run Disk Utility again.

  • I access the Mac Mini via remote desktop from an Macbook Pro, as it runs headless. The option key is not stuck down. The Repair Permissions option has been removed on El Capitan (thanks Apple). – rf_wilson Aug 15 '17 at 17:22
  • You can do it from Terminal, "sudo /usr/libexec/repair_packages --verify --standard-pkgs /" Run that (without quotes), it will ask for your password and will force a repair of permissions. – Steve Chambers Aug 15 '17 at 18:00
0

Typically, a users .Trash directory or a .Trashes directory on mounted filesystems has been unlinked. A reboot should recreate any missing directories.

Not the answer you're looking for? Browse other questions tagged .