1

I tried to connect to a public Wi-Fi on my MacBook Pro but can't do that. When I opened the network configuration it says something like "self assigned IP". In the meantime my iPhone connects to that Wi-Fi just fine.

I've tried all methods that I can find online, including renewing DHCP, deleting preference files in system folders, rebooting, deleting access passwords. None of them worked. I'm not connecting via router/modem so can't reset/restart them.

  • 4
    Problems like this are almost always the network. Do you have reason to believe your Mac is the issue? Taking it to a new network would be the quickest way to rule it our and get the person running the wifi that won’t assign an IP address to check that it’s not broken or over capacity. – bmike Aug 14 '17 at 23:57
  • Can you setup your iPhone as a hotspot and try connecting to it that way? If it works, there's a very good chance that the DHCP lease pool is over subscribed. – Allan Aug 14 '17 at 23:59
  • @bmike Very helpful! I talked to the wifi provider and indeed it's their problem, as my computer can connect to other wifi hotspots. Thanks again. – Yining Wang Aug 15 '17 at 19:32

You must log in to answer this question.

Browse other questions tagged .