1

This question already has an answer here:

I am having issue with my trackpad of MacBook Pro Retina early 2015, As it was working properly a day before, the Hardware Keyboard and other things working properly.

I did tried Reseting SMC, PRAM, but no luck, I am on macOS Sierra 10.12.6.

Any suggestions?

marked as duplicate by Allan, bmike macbook Aug 14 '17 at 12:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please ignore the “ask a new question advice” above. An edit to explain precisely what has failed and a flag to review the close is better if the question at hand is not a duplicate. – bmike Aug 14 '17 at 12:02
2

I would start with the following:

  1. Go to Apple > System Preferences
  2. Select the Trackpad preferences pane
  3. Check your various settings under each of the tabs

If nothing there resolves the issue, then try booting into Safe Mode to see whether booting into Safe Mode makes a difference, either during or afterwards.

NOTE: Before proceeding below I recommend disconnecting any external devices (e.g. keyboard, mouse, etc). This also includes Bluetooth devices as well as USB.

Boot into Safe Mode

Follow these steps to boot your Mac into Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. does your trackpad work, etc)
  6. Exit Safe Mode by restarting your Mac as normal
  7. Again, take a note of what happens (i.e. does your trackpad work, etc)

Now, if after you've gone through the above steps you find that:

  • your trackpad works during Safe Mode but not when you're logged back in normally, let me know.
  • it isn't working during Safe Mode at all, then it's time to test your hardware with Apple Diagnostics (see below).

Run Apple Diagnostics

Follow the steps below to run Apple Diagnostics:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the D key and keep it down until you see the Diagnostics screen appear
  4. Wait for Diagnostics to finish (this typically only takes a few minutes)
  5. Once complete, one of two things will appear on the screen:
    • a No issues found message
    • a brief description of any errors found plus further instructions
  6. If the diagnostics test does find errors, take a note of what they are

Note: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

Regardless, take a note of what happens and let me know how you went.

  • An excellent triage sequence. I might suggest adding an “isolate all pointing devices” step before doing safe boot, etc... apple.stackexchange.com/questions/295164/… – bmike Aug 14 '17 at 12:00
  • Hello. This was really useful. I tried most of these things and they partially worked, until the keyboard (and pad) COMPLETELY stopped working. The power button works, and the trackpad "clicks" (which is a software feature in my 2016 Mac Pro). But i can't start it in safe mode or in diagnostics mode because the keyboard doesn't work. Using an external keyboard doesn't work (for boot) either. External Keyboard and mouse work AFTER booting. Any idea? I'm going crazy. I'll contact Apple support tomorrow as I ran out of ideas, but maybe you can think about something else. Thanks very much! – santiagobasulto Sep 9 '17 at 3:39
  • Btw, when I got to run Diagnostics (a few days ago was coming and going) if found NOTHING wrong. – santiagobasulto Sep 9 '17 at 3:42
1

Try to press firmly on touchpad itself and palm area of the MacBook few times. If after that touchpad will come back to life, then most probably you have problem with the battery. You'll need to replace it in a service center. I had similar problem with my MB.

0

Try to get any mouse and go to system preferences by clicking on the apple logo in the top left. Then go to accesability then mouse and track pad. If you have "mouse keys" enabled uncheck it then you should be alright. If this is not the issue and you have tried everything else then you might have a hardware issue.

  • tried every thing possible ! – dip Aug 14 '17 at 9:23

Not the answer you're looking for? Browse other questions tagged .