2

I try to install NetBeans IDE on my MacBook Air (2017) with macOS Sierra. I tried both from .dmg file and directly with Homebrew, with the same result - the installation freezes. Have any of you guys had this problem?

Here is the screenshot of what I've been seeing for like 2 hours:

enter image description here

5
  • Have you installed the full Java implementation? See this question and answer at AskDifferent. – IconDaemon Aug 13 '17 at 10:11
  • 1
    I doubt it is a duplicate of the problem you pointed out. I have idk 1.8 installed (as you can see on screenshot, it looks for the path and this path in fact exists, I checked that) and I don t get any error suggesting me that NetBeans cannot find java. MacBook-Air-Kamil:src kamcio$ javac -version javac 1.8.0_144 – DanoPlurana Aug 13 '17 at 10:24
  • Could you edit how you test your jdk and version into the body of the question? That would make it look different than the duplicate and trigger a review to reopen. I wonder if you need a brew modification +java to indicate you have full jdk installed. apple.stackexchange.com/a/251288/5472 – bmike Aug 13 '17 at 13:49
  • What does the screen and log show for the .dmg install (having a password prompt where it is looks odd - I assume you entered your password there – mmmmmm Aug 13 '17 at 14:06
  • well I reinstalled my JDK and it finally worked. It took like 30 min for the Installer to finish it's job, which is kind of strange, but anyways, it works now, thanks for your answers and help – DanoPlurana Aug 14 '17 at 0:14

Browse other questions tagged .