1

Ive got a mac mini running El Capitan, i use a piece of CAD software which requires me to use the "mouse scroll wheel click" to move around the software.

This works fine on other machines that i have the software installed on which are running Yosemite, but on this machine running El Capitan the "mouse scroll wheel click" shows all windows, the same as pressing F3.

Is there a way to disable this feature in El Capitan ?

For reference im using a logitech LS1 Laser mouse which is a simple mouse which works plug and play, its not a fancy gaming mouse, and it driver software is quite limited (see attached screenshot of options). But because of the way the issue is only showing up in El Capitan im thinking its an issue / setting in the OS rather than on the mouse.

screen shot of logitech mouse setting software

1

I suspect El Capitan is interpreting this action on your Logitech LS1 Laser mouse as a double-tap with two fingers.

Assuming this is the case, you can try this:

  1. Go to Apple > System Preferences
  2. Click on the Mouse preference pane
  3. Select the More Gestures tab
  4. Uncheck the Mission Control box
  • thanks ill give that a try, ive updated my question slightly as after some digging i found the mouse does have a settings app, but the options it gives you are limited – sam Aug 12 '17 at 17:30
  • i tried finding the setting in system preferences, but got stuck on step 3, there wasnt a More Gestures tab, is that something you only get if your using a mighty mouse ? Here is a screenshot of the options i got : imgur.com/a/BSkpu – sam Aug 14 '17 at 9:26
  • Hmm, not sure why you haven't got the option, but no you don't need to have a mighty mouse or magic mouse to get it. Looking at the image you've added to the question, what options do you get to select a different assigned action to the wheel button? I suspect you may be able to change this to something that may resolve (or get around) your issue. – Monomeeth Aug 14 '17 at 12:18
  • ive just been digging deeper into the mouse driver and i found some settings which resolve the issue ! see screenshot here : imgur.com/a/jYIsU – sam Aug 14 '17 at 19:08
  • Excellent! I suspected a different assigned action may do the trick. Can I encourage you to add an answer to your own question, as this will likely help others. :) – Monomeeth Aug 14 '17 at 22:56
0

The solution was to use the mouse's driver / settings menu to configure what the centre button does. In the logitech software there was an option to set what the centre mouse wheel button does when clicked. See screenshot below of the options it provides, i would presume most other major mouse manufactures have software similar to this for their products.

screenshot of logitech LS1 mouse driver

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .