1

After a failed Linux installation I'm unable to extend my Macintosh HD logical volume to recover unused space. I'm on v10.12.6 of macOS Sierra. Trying to remove the "Free space" partition in Disk Utility results in a message of

The requested size change for the target disk or a related disk is too small. Please try a different disk or partition, or make a larger change.

Since it's a ~20GB change I'm not sure that's the problem. I've tried using the Disk Utility First Aid tool on the physical disk and logical volume.

I'm nervous about using the diskutil coreStorage resizeVolume command since a) it doesn't seem to use the /dev/disk0s2 identifier and b) I've read that it's unsupported (but does show up in diskutil coreStorage on my version of macOS).

Attached are the Disk Utility and diskutil list output for more info.

disk util window diskutil list

1

Try booting from recovery or install media and following the same procedure. Usual caveat: make a full backup of things just in case.

I've had the same situation as you and it worked for me, the only difference was my drive was Time Machine rather than a boot volume. The route I took was make a bootable USB drive with DiskmakerX[1] rather then in-built recovery partition on the Mac.

[1] http://diskmakerx.com

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .