I'm facing the weirdest issue and have spent hours googling a solution but returned empty-handed. I have a Mac early 2015 laptop with OS X Sierra(10.12.5) installed on it. Whenever I try to save a word/ppt/xls/txt file with Word/Powerpoint/Excel/TextEdit, the dialog box doesn't show up. There's no confirmation of whether it's been saved or not and I have lost hours of work because of this issue. Has anyone here faced this issue before?


  • I know this is kind of the obvious one, but is the dialog box still not showing up after a reboot? – YourMJK Aug 11 '17 at 3:40
  • yeah, it's not showing up – user2103008 Aug 11 '17 at 4:55
  • What happens if you Save As... ? – Tetsujin Aug 11 '17 at 5:52
  • Nothing ... no dialog box shows up – user2103008 Aug 11 '17 at 17:13
  • Step1: Open a textEdit and add some text into that (fig1)

enter image description here

  • Step2: press cmd+s and the following window will popup(fig2)

enter image description here

  • Step3: enter filename and specify the location to save (fig3)

enter image description here

  • Step4: press save button at the bottom of the window
  • Step5: Now this text document is saved and the - Edited in the title is disappeared(fig4)

enter image description here

from now onwards when you want to save some text or documents you can press cmd+s and for conformation you can check whether - Edited is there in the title or not. If - Edited is still there means the document or whatever it is not saved. Hope this helps. By the way, i am using Mavericks hopes its the same with OS X Sierra

| improve this answer | |
  • I tried all ways to save but it doesn't work ... the window you mention won't show up – user2103008 Aug 11 '17 at 4:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .