1

When viewing some files with quicktime on my retina MacBook Pro (Sierra 10.12.6), I can view it on Apple TV and the sound works fine.

However some files produce the following behaviour:

  1. Select Apple TV / Airplay in Quicktime. Video appears on TV, but no sound (on TV or laptop).
  2. I click on the Sound Pref Pane and select Apple TV as the output. There is a slight pause, then the video switches back to the laptop, and the sound now comes out of the Apple TV

This is a similar problem to those reported here and here, but it's not exactly the same because the solutions suggested don't work for me, and this is consistently happening but only for a subset of my video files.

NB this exact same behaviour also happens when watching youtube videos in Safari.

  • Have you tried other (ahem, better) video players, like VLC? ATV's themselves (and QT too, I think) are VERY sensitive to the audio encoding, especially if you ONLY encoded with mult-channel sound (no stereo track). VLC's Get Info window will show you the encoding details (or you can use ffprobe if you prefer the Terminal), and maybe you can detect a difference between the files that work and those that don't. – jimtut Aug 14 '17 at 18:03
1

Have you tried adjusting the “Audio Mode" and the “Surround Sound" settings in Settings ➔ Audio and Video? It may be worth trying several combinations of these settings, although typically it is the “Surround Sound" setting that causes most problems for users.

Your TV may not support pass through or you may need to map the audio to the optical output.

If it still doesn't work you might try one of these.

HDMI to HDMI + Audio (Example Only - Not a recommendation or suggestion that this is suitable in your circumstances)

  • "Surround Sound" is not an option in the "Audio and Video" menu of my Apple TV (A1469, software version 7.2.2). – mdarwin Jan 31 '18 at 21:46
  • Thanks: I tried setting "Audio output" to 16 bit and Dolby Digital to off in the Apple TV, but still get the same result. – mdarwin Aug 12 '18 at 19:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .