0

I want to be able to hear the system beep. Normally, this can be done by running any of the following commands in OSX:

  • echo -e "\a"
  • printf "\a"
  • tput bel

Running these commands in the standard Terminal app (Version 2.6.1 [361.1]) produces no visible or audible effect.

Running these commands in the iTerm2 app (Build 3.0.15) produces a small, golden bell next to the tab name at the top of the window, but produces no sound. If I enable the "Flash visual bell" setting, I get the small, golden bell plus a larger bell icon over the whole terminal window, as shown here:

screenshot of terminal window showing visual bell

The profile I use has what appear to be the correct settings: iTerm2 Profile settings screenshot

For comparison, say "hello world" makes the computer speak "hello world" audibly -- my speakers are not muted.

Note that this question is similar, but asks for the special case of enabling sound in certain situations but not others.

1

Turns out that I hadn't selected an alert sound yet in System Preferences. Once I chose an alert sound, all three of the above methods produced audible system beeps, in additiona

To enable audio alerts, I chose an alert sound from the Sound tab of the System Preferences:

Screenshot of the Sound tab of System Preferences

I chose "Sosumi" out of nostalgia for my IIci days.

Alternatively, this can be set as described in this answer, though iTerm2 needs to be restarted for it to take effect in Sierra or El Capitan:

defaults write com.apple.systemsound com.apple.sound.beep.sound /System/Library/Sounds/Sosumi.aiff

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .