After updating Yosemite on an iMac 2011 for some reason my F keys on my magic keyboard stopped working. When I researched the only question I was able to find was "Function keys Magic Keyboard not bound correctly" but that is for Mavericks.

I've gone into settings and tried Change Keyboard Type.. but that hasn't changed the beeping behavior when I click an F key.

I've tried both wired and wireless connections and I've removed the keyboard from the Bluetooth.

When searching I found Why are my top-row keyboard buttons not working on Mac Lion? but I dont have all those options:

enter image description here

Diving deeper I found Top row of keyboard isn't working so I unplugged my iMac and let it sit for an hour. Logged in and re-connected the keyboard and the same issue occurs.

Mac system specs:

  • OS: Yosemite
  • Version: 10.10.5
  • iMac 27-inch, Mid 2011

App Store says no more updates available. How can I get my F keys back?

  • 1
    Same problem here. Been on the apple support call for 1 hour now and they still haven't found anything to help me. I'll just go back to the store and exchange it for a wired one.... nevermind, they don't sell them anymore... -_- Commented Sep 5, 2017 at 22:01

1 Answer 1


I had a similar problem using a magic keyboard 2 on High Sierra (iMac late 2013). I tried several programs such as Spark or Function flip, even tried Applescript. The only solution for me was installing Karabiner-Elements https://karabiner-elements.pqrs.org/. There is a version for Yosemite - click on the arrow next to download and you get all the options. enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .