1

So I decided to use my old MacBook Air 2012 as a Windows laptop. I installed Windows 10 Anniversary using boot camp. Everything went well and I've installed a bunch of programs, Visual Studio, etc. It builds perfectly and everything works great.

Except for one thing: the down arrow key does not work!

I've installed the latest driver updates using the pre-installed apple update software. For some reason there is no boot camp control panel installed.

Not sure how to fix/debug this!

1

Try booting into the recovery mode (Hold CMD + R at boot) and test wether it works there, if it does then is a software issues and a full bootcamp reinstall may be required if it doesn't then its likely a hardware issue in which case a repair would be your best bet. Also the absence of BootCamp Control Panel points to it being a software issue/driver, attempt the above and if it works try a reinstall following Apples tutorial to the letter! Good luck

  • I tried booting into MacOS and the key does not work there anymore either! This is really strange: I'm certain that it worked right up until I boot camped the computer! – Jonatan Aug 10 '17 at 8:48
  • Given the age of the machine its entirely likely that its a hardware issue, check your serial number to see wether its still covered for repairs (not warranty as thats far gone) and see what Apple say, if not third-party repair? Good luck – Ryan Aug 10 '17 at 8:50
  • I pulled off the key and pressed it a few times with the key removed, blew away some dust, and it worked again. :D Thanks for your help, I was 100% sure it was a driver issue! – Jonatan Aug 10 '17 at 8:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .