1

Using Apple Configurator 2. I connect an IPad and hit prepare. It says that the device has already been prepared.

I erase the device, it restarts and goes through all the steps for setup (even though I chose to skip all steps for prepare).

On the apple configurator 2, during the restart process it tries to "Downloading activation records for device" and keeps going step 1 of 2, then 2 of 3, 3 of 4 etc.... It continuously fails and won't see the IPad as prepared.

The device restarts and appears like a regular device that I can setup as one usually would from the store.

I have no idea how to get the ipad to prepare so I can run it in single app mode.

Update During setup it states the iPad is linked to my account (it was setup once before as a normal iPad).

  • I have updated my ipad and my computer to latest software – msj121 Aug 10 '17 at 15:35
  • I have the latest version of Configurator and MacOS, am getting this same issue on a 5th Gen iPod touch ( maxed out at iOS 9.3.5) – callisto Sep 21 '17 at 11:37
1

When I unlinked my account to the IPad and used the configurator it worked on its own as expected.

  • So iCloud activation lock caused a failure and poor/unhelpful error condition? – bmike Sep 25 '17 at 0:36
  • This didn't work for me. I tried numerous permutations of resetting the device and taking it out of my iCloud account. – Eric McNeill Dec 13 '17 at 18:41
  • I think that my issue had to do with some of the preferences on my account like finding the device if lost. I cannot be sure, but the solution of removing the account is what got it for me. – msj121 Jan 4 '18 at 4:46
1

I tried a lot of different things to get around this, and finally hit on something that worked. Unfortunately my last attempt included several tweaks, so I'm not yet sure what the magic bullet was...

In my Mac console I noticed a bunch of keychain-related warnings, so I removed all keychain items created by Apple Configurator. Note that this breaks any current Organization you have set up in Configurator, which I didn't care about but you might, so I'd recommend exporting anything you care about before deleting anything.

MacOS error: -25304         // errKCInvalidItemRef = -25304
CSSM Exception: -2147417855 CSSMERR_CSSM_INVALID_ADDIN_HANDLE
MacOS error: -25304
CSSM Exception: -2147417855 CSSMERR_CSSM_INVALID_ADDIN_HANDLE
MacOS error: -25316             // errKCDataNotAvailable = -25316,
MacOS error: -25305             // errKCInvalidSearchRef = -25305
could not enable test hierarchy: ApplePinningAllowTestCertsAppleSWUpdateSigning not true
could not enable test hierarchy: ApplePinningAllowTestCertsPackageSigning not true
could not enable test hierarchy: ApplePinningAllowTestCertsMacAppStoreReceipt not true
could not enable test hierarchy: ApplePinningAllowTestCertsAppleIDAuthority not true
WARNING: SecPolicyGetOID failed to return an OID. This function was deprecated in 10.7. Please use SecPolicyCopyProperties instead.
0x608000277c00 opened /Users/ericm/Library/Keychains/login.keychain-db: 1383760 bytes
CSSM Exception: -2147415780 CSSMERR_CSP_INVALID_KEYATTR_MASK
CSSM Exception: -2147415780 CSSMERR_CSP_INVALID_KEYATTR_MASK

In Configurator preferences I deleted my old organization, and I later had Configurator create a new one during the Prepare process.

I signed out of iCloud on the device.

At this point I still hit the same error trying to prepare the device:

Configurator could not perform the requested action because “Name of iPhone” has already been prepared.

Click “Erase” to erase and prepare the device again. All content and settings will be deleted. This cannot be undone.

I'd been through the Erase process enough times this week to not have much luck that it would work, but I decided to try it one more time, and also log into a different iCloud account (that this device had never been associated with) when the device came back up. In the end the device was Supervised.

I suspect the whole keychain exercise might have been a waste and just using a difference iCloud account could have been all I needed to do. If I get a chance I'll try to narrow it down on another device I've been having problems with.

0

I had a similar issue and here is what worked after so many attempts: - Use iTunes to Restored the ipad to the Factory setting - After restore, when it gets to the point where you are asked to set it up as a new iPad or restore from a backup, click CANCEL - Connect it to Apple Configurator again and prepare it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .