37

I am trying to edit a line of code within a program that I use for work.

I need to use the insert key to be able to add additional spaces that I can then type letters, numbers or characters.

How to get this function to work on my MacBook Air?

3
  • 2
    What program are you using on your MBA that requires an insert key? In that program are you certain that the Insert key will do what you expect on your MBA? Try plugging in a PC-style USB keyboard and pressing Insert in the program; does it work as expected?
    – adamrmcd
    Commented Oct 29, 2011 at 6:49
  • What country / language keyboard are you using?
    – MrDaniel
    Commented Jul 31, 2012 at 22:09
  • Related: Simulate INSERT key in Mac OS X
    – kenorb
    Commented Sep 14, 2016 at 19:32

6 Answers 6

18

I need the insert key in the Midnight Commander (MC) running in Terminal and in Remote Desktop Connection (RDP) when connecting to my Windows PC.

For Midnight Commander the answer is Ctrl+T.

For RDP I did not find better solution than to use a free program on Windows AutoHotkey and map the key to chosen key combination, for instance this macro maps the Insert key to Ctrl+Alt+I :

^!i::
Send {INSERT}

Answer found on Microsoft forum

1
18

FN + Return = Insert

(MacBook Air 13)

Also Works on MacBook Pro.

6
  • 10
    fn-return is normally enter.
    – Lri
    Commented Sep 5, 2012 at 11:11
  • 1
    This actually worked for me, also MBA 2013. Upvote. Commented Jul 28, 2013 at 19:13
  • 1
    This worked for me on an MBA 2013, running Windows
    – Dexter
    Commented Jan 11, 2014 at 2:22
  • Same here on an MBA 2013 using ArchLinux.
    – WhyNotHugo
    Commented Feb 27, 2014 at 6:55
  • 1
    doesn't work for me, Sierra, Macbook pro 2014 retina
    – Sleepyhead
    Commented Oct 10, 2017 at 10:34
4

It depends on the physical keyboard and on the keyboard layout. You can try...

ctrl+fn+M OR ctrl+fn+

2
  • Finally, something that worked. CTRL+FN+M worked on my MacBook Pro (4,1). Everything else failed.
    – NuSkooler
    Commented Apr 24, 2015 at 3:26
  • Nah... fails on my Macbook 2015 with Catalina..... Come on Apple, for petessakes !!!!
    – AlexD
    Commented Aug 6, 2020 at 16:42
4

FN + Return works for me to insert.

4
  • 8
    Your answer here is merely a repeat of an existing answer. In addition to posting a short confirmation, be sure to mark up the existing answer that you agree with. Commented Oct 25, 2012 at 20:02
  • Worked for me, MBA 2013 Commented Jul 28, 2013 at 19:13
  • Not always... not for on my Macbook 2015 with Catalina - it merely insert a new line.
    – AlexD
    Commented Aug 6, 2020 at 16:42
  • Doesnt work on Sublime
    – frewper
    Commented Apr 7 at 7:16
1

I posted a possible answer to this question in a similar question topic on StackExchange:

How do I simulate the Insert key in Windows on a MacBook Pro?

In it, I'm explaining how to re-map the key combination Fn+Ctrl to Insert using Karabiner.

0

On the latest Macbook Air 13" ctrl+ works.

1
  • "Latest" changes over time. It would have been better to explicitly say the model/version in your answer. For instance, in the "latest" MacBook Pro (with Apple M3 Pro) running the "latest" Mac OS X Sonoma 14.5, this combination doesn't work. Commented Jul 8 at 13:31

Not the answer you're looking for? Browse other questions tagged .