3

I like this font and it's my default on Linux, so I tried to start using it on macOS (Sierra) too. The result is pretty awful and I don't understand why, in particular what puzzles me most is the fact that the lines are not parallel/perpendicular.

enter image description here

I suspect that this concerns the fact that originally Terminus is a bitmap font, but I don't know what to try next.

Do you have any ideas?


Update: As an alternative font similar to Terminus that appears to work out of the box you can try GNU Unifont.

4
  • 1
    In order to use the Terminus TTF font effectively, you must disable anti-aliasing and use a supported size in the application you are using it in. The only application that I know for a fact allows you to disable anti-aliasing is Terminal.
    – 0942v8653
    Sep 2, 2017 at 18:15
  • @0942v8653 Much better actually, but still looks weird compared to what I was able to obtain using the above steps (updated question).
    – cYrus
    Sep 3, 2017 at 12:53
  • The solution should not be an edit but an answer
    – mmmmmm
    Sep 5, 2017 at 14:18
  • @Mark: it's now an answer.
    – cYrus
    Sep 5, 2017 at 16:45

4 Answers 4

3

What type of font is this? -> Which Terminus font are you using?

If you are using indeed a font copied from somewhere that macOS can not deal with properly, and you are just looking for a version that displays OK under macOS, then you might want to take a look at a TrueType version of Terminus.

The actual outlines are very crooked in that font. Take a look at these with e.g. fontforge: Terminus outline ttfIt displays OK in small sizes. Turn antialiasing on and off to see which version you like better. But a size >14Pt is almost unusable anyway.

In larger sizes it gets ugly fast. The autotrace/potrace process, as used by the linked font, would need a lot of cleanup manually. If you insist on using this font and that it better upscales uncrooked you might need to clean it up. With FontForge or similar software that is a tedious process and will take a while.

Or you can try another conversion yourself. Starting with the xfonts-terminus package from your Linux installation in .pcf.gz-format might get you there a bit faster (/usr/share/fonts/X11/misc/ter-u12b_iso-8859-15.pcf.gz).

You really have to love that font very much to do so. Another font will perhaps be the better option. But try this conversion if you do not need that many sizes.

Update: A much better, ready made version of Terminus can be found here.

Terminus outline Terminus preview

When using these fonts the so-called "OS-X-optimized versions" seem to be problematic. The actual fonts to use are the "regular" ones at http://misc.nybergh.net/pub/fonts/terminus/ttf/Terminus.ttf and http://misc.nybergh.net/pub/fonts/terminus/ttf/TerminusBold.ttf

Unfortunately the bold variant has several issues that prevent a successful validation of the fonts. However they are accepted by the system and used for display. Only some characters have their glyph position misinterpreted by the system. To fix this one might simply save the bold variant as a newly generated font. That automatically reduces the most egregious character misplacements.

Using FontForge the visual improvement from a simple re-generation is obvious (but still not perfect and the validation issues are inherited):

FontForge regenerated Terminus-Font

This is done by installing FontForge, opening the bold version of the font, and simply choosing "File>Generate Fonts" from the menu (ignoring the validation error). If using the bold variant is important, a manual cleanup of the newly created file is still strongly advised.

8
  • I'm using the TTF version (both versions look the same, see the list in the screenshot). Are you able to make it right?
    – cYrus
    Sep 2, 2017 at 16:21
  • 1
    OK, that conversion kind of worked, I guess this is the best I can hope for now. Thanks!
    – cYrus
    Sep 3, 2017 at 11:44
  • 1
    It worked quite well actually, I updated the answer to add the full process.
    – cYrus
    Sep 3, 2017 at 12:51
  • About the update: that version doesn't seem to work for me, the preview in Font Book is blank and the font is unusable in applications.
    – cYrus
    Sep 21, 2017 at 13:17
  • 1
    Right. The "regular" bold version needs some cleanup in just 4 glyphs(self-intersections) and indeed shows up with borked metrics on the glyphs you mentioned with default macOS editors. But both of these types of problems are almost easy to at least mitigate semi-automatically with FontForge. Sep 21, 2017 at 14:28
2

Probably this has something to do with it:

About the outlines

There are applications that neither support the original Terminus Font nor use bitmaps embedded in TrueType fonts. They completely rely on the automatically generated scalable outlines.

When Terminus TTF is used with such applications, it will probably look a little bit weird and not exactly like the original Terminus Font (since the generated outlines do not exactly match the bitmaps); you will see whether you like it or not. Because the outlines are scalable, it should not matter which size you use, but anything bigger than 32 px (24 pt) will probably not look very nice. I have no idea how sizes smaller than 12 px (9 pt) look; feel free to report back.

(src)

Doesn't sound like there's anything to be done about it, except maybe find another font that looks similar enough to work for you.

1

The accepted answer provided some useful hints, especially the linked workflow. Follows what worked for me specifically about the Terminus font:

  1. download terminus-font-x.yy.tar.gz from here;

  2. extract it (you'll need the ter-u*.bdf files);

  3. pick a size (16pt worked well for me) and open ter-u16n.bdf and ter-u16b.bdf in FontForge;

  4. for each do File -> Generate Fonts with No Outline Font and Apple bitmap only sfont (dfont) and choose ~/Library/Fonts/ as destination;

  5. two files will be created: TerminusMedium.dfont and TerminusBold.dfont;

  6. Just use Terminus as font name and 16pt size in your application.

1

Terminus font is now nicely packaged in a Homebrew cast for easy installation:

brew tap homebrew/cask-fonts
brew cask install font-terminus

Select "Terminus (TTF)" in preferences. In my experience, changing font size requires restart of the Terminal app (not just window).

Font size 14: enter image description here

1
  • 1
    Yes, and it presents the issues described in the question...
    – cYrus
    Aug 10, 2018 at 0:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .