2

My iPhone is connected to iCloud with the same account. In Messages → Preferences, under "You can be reached for Messages at:" my iPhone's number and my iCloud account are both there and checked.

I have tried restarting Messages, my MacBook, as well as turning iMessage off and on from my phone, and removing the files from ~/Library/Messages. Nothing so far has worked.

My computer is running El Capitan, and other applications (such as Notes) can sync over iCloud just fine.

  • 1
    Are you trying to send iMessages (to other iCloud users), or plain SMS/MMS messages? – user11633 Aug 8 '17 at 5:04
  • Idealing SMS/MMS messages, but I'm pretty sure it would automatically send iMessages to other users with Apple devices. – gsamerica Aug 9 '17 at 15:23
1

The first step would be to make sure you can send iMessages to other iCloud users. If not, then you’ll want to Sign Out of iCloud under MessagesPreferencesAccounts. You may need to reboot your MacBook before signing back in.

If it’s regular text messages (SMS/MMS) that aren’t working, on your iPhone open SettingsMessagesText Message Forwarding and make sure your MacBook is enabled. If it already is, toggle it off, then back on. You will be prompted to enter a verification code sent to your MacBook.

If none of this works, you may need to reboot both devices with everything disabled, then reactivate everything only after booting back up.

  • 2
    That was it: text Message Forwarding was not turned on! I would have thought that it was automatic, considering the last time I had an iPhone it connected everything right off the bat. Thanks very much. – gsamerica Aug 11 '17 at 19:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .