3

I have desktop Windows PC with a large display and nice keyboard and mouse setup. I have a Macbook that I would like to use with the same setup. My monitor does not have any more available input ports.

Is it possible to run a desktop session from my Macbook within a Windows application? I'm aware of VNC, however that seems to mirror what my Macbook is currently displaying. If possible, I'd like to run a new GUI session that runs at the correct resolution of my Windows display. Bonus points if I can leave my Macbook's lid closed whilst accessing it from Windows.

2

You won't get closed clamshell mode unless you connect a display and power, but that's how I run many portable Mac so they do work well in that mode even if it's not what you look for specifically.

The Mac supports two log in users - so if you have one user logged in locally - you could VNC in with a second account and it will ask if you want to share the screen or have your own session.

One nice trick if you don't want to connect an actual display in closed clamshell mode, you can connect an adapter like this:

Should be pretty straightforward for you to do either of these - it just takes connected items and/or two accounts.

| improve this answer | |
  • Weird that this requires a separate dummy account, but I guess I could live with that. This does work, but it still runs a session at the Mac's native resolution. Is there any way to force the desktop to run at a resolution my Windows client VNC requests? – Chris Horner Aug 7 '17 at 1:36
  • You can't change the resolution in VNC. But it is possible to buy a display emulator dongle that is often used with Mac Mini Servers to get a bigger VNC session. – John Keates Aug 7 '17 at 1:48
  • Yes @JohnKeates. apple.stackexchange.com/search?q=Vnc+resolution And there are dongles to upscale things of you want to go closed clamshell at 4K resolution, for instance. – bmike Aug 7 '17 at 2:08
  • That's absolutely perfect! Pop the note about the adapter in the answer and I'll mark it as accepted. – Chris Horner Aug 7 '17 at 3:49
  • For anyone reading this in the future, the adapter that solved my problems was this one: fit-pc.com/web/products/fit-headless-gs – Chris Horner Aug 7 '17 at 6:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .