2

My Early 2015 13" MBP's keyboard and trackpad quit working a few days ago. I thought it might be the logic board. But it’s definitely not. The power button (on the keyboard) works fine.

I tried a few things (below) more than a handful of times. Eventually, I realized I could just plug in an external USB keyboard & mouse. By that time my Mac was trying to get me to disable FileVault in some weird boot mode that I've never seen. So I did.

Things I've tried:

  • SMC reset (actually worked -- confirmed with the power adapter light)
  • PRAM reset & all other boot options -- totally unresponsive
  • used nvram -c in the terminal to reset the PRAM -- verified this worked
  • disabled filevault -- nothing
  • booted into USB installer to test keyboard and mouse -- nothing

None of the above things worked -- I also tried various SMC resets and PRAM resets after each steps and in different orders.

Here's the important thing: even with an external keyboard, no boot options work... except SMC resets. Which leads me to ask... is something wrong with the kernel?

I've tried safe boot, verbose boot, PRAM resets, recovery mode all from on computer keyboard and external keyboard. Nothing is responsive at time of boot.

I should note, I'm writing this from the MBP with external keyboard & mouse.

1

I did some research and apparently, the early 2015 MBP is known for having trackpad/keyboard cable issues. I reset the cable and boom it works!

  • What do you mean by reset the cable? – Pacerier Mar 1 '18 at 18:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .