After a forced shutdown, my white MacBook hangs at the gray screen with the Apple logo and an infinitely spinning progress wheel.

I can boot in verbose mode, but I didn't see any particular error, just a timeout (I can provide the verbose text, but I'm at work and my Mac is at home).

I can't boot into single-user mode. It just sits at a similar point as the verbose mode.

I booted off my Snow Leopard install DVD. It took nearly 10 minutes! Once it got the install screens, I ran Disk Utility. It sees the internal hard drive. It sees the partition. Info on the partition shows that it is an HFS partition. But, it's grayed out and unmounted. If you click "Mount" it says that it cannot be mounted - run First Aid.

"Verify" runs for about 8-10 minutes, shows messages for each step, no errors, and then says Verify has passed. Still won't mount. "Repair" runs for about as long, shows no errors, shows no repairs. Still won't mount. Grrr.

I hooked up an external drive and created an Image of the drive. This took hours. Completed with no errors. I then tried to mount the disk image (.dmg). It ran a full Verify (I don't know how long - I fell asleep). It Verified, but said it couldn't be mounted and suggested I run First Aid. Verify passed. Repair is grayed out. Won't mount.

What should I do next? I'm going to replace the hard drive no matter what, but my last Time Machine backup was 7 months ago (I know, I know, ...) and I would like to, hopefully, get to the last 7 months of files.

It's the only Mac I have, so I can't do the Target disk thing.

DiskWarrior? Any other utilities (particularly free ones) to try? Bootable Linux utilities?

Also, assuming file-system corruption, could my external disk image be processed by disk utilities just as easily as the hard drive? In other words, if I erased my hard drive and repartitioned and reinstalled the OS, would I be any worse off in regards to maybe recovering files if I just deal with the external Image?

Otherwise, I'll probably replace the internal drive, reinstall, then but the internal drive in an external SATA-to-USB enclosure and work on it from there...

2 Answers 2


When this happens to me, I've found that resetting the PRAM/NVRAM often works. (Sometimes it takes a couple restarts to see any results.)

Also, if you haven't already done so, take a look at Apple's troubleshooting steps for this problem.

  • I did the PRAM reset once and it didn't do anything, but I could try it again a few times. I tried the safe boot, but not the Verbose Safe Boot, but I'll go through the Apple suggestions one at a time. I want to be sure I've exhausted all avenues before re-installing.
    – CMPalmer
    Commented Oct 27, 2011 at 16:52
  • YA, there have been times where I've done it several times and I give up only to have the computer boot successfully as I get out of my chair. A watched Mac never boots? Commented Oct 27, 2011 at 16:55

I did put my mac book pro's disk on a case, the from another mac I erased all the /System/Library/Extension/AMD*. (How to disable discrete graphics card and use only integrated graphics MacBook Pro Early 2011?).

I was able to boot on the Original 2011 Macbook Pro 15''

El Capitan make imposible to boot in the single user mode and move all those files because of the sandbox. When I try to boot in recovery mode I had a Gray screen too.

The only way was to erase those files from anotner mac...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .