2

I recently got mac mini and I'm new to OS X so maybe this is a trivial question. I'm developing web application in java using Spring. I have another project to run IT tests which sets up the API and performs lots of testing.

Tests take ~6 minutes on Linux and Windows (and when this is first thing i do after restarting my mac). When i run them on my mac they take very long time (~30 mins and go on) I notice in Activity Monitor that CPU is 90% idle after the API has started and tests begin to execute. Java processes uses ~0.5% of CPU. There is still ~7 GB memory free.

Running this on other environments (e.g. Linux) usually takes most of available resources (almost 100% CPU usage and memory)

Can somebody help me resolve this issue? Does OS X have any limitation regarding CPU usage for java processes?

I can provide more informations but need to know where to look.

6
  • Is your "IT test [suite]" available in the public? – klanomath Aug 3 '17 at 13:51
  • are you asking about project sources? It is not available in public. – Łukasz Żarczyński Aug 3 '17 at 14:03
  • Are you running it via command line or an IDE? (Some IDEs negatively affect performance). Also, is the program throwing any uncaught errors? – NoahL Aug 3 '17 at 14:10
  • No errors- test do execute but very slowly. Running it via command line using maven – Łukasz Żarczyński Aug 3 '17 at 14:15
  • I'm using Check Point endpont security to connect to VPN. Disconnecting seems to resolve this issue which makes me even more confused – Łukasz Żarczyński Aug 3 '17 at 14:50
0

Is the console output slowing the application? Does the app use System.out or a logging framework like log4j?

I just solved a similar issue for a Java app and the behavior occurred after an update - the MySQL slow query log showed that the insert was taking 1 second but in reality a batch insert was being split into 1000 some inserts after the default behavior in the JDBC driver changed from auto commit being off for batch commits to having it on (which required me to manually turn off auto commits for batch inserts).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .