4

Suddenly, existing text strings are showing the contact number (not for all text messages), and not the contact name, on my iPhone 6. If I look for the person in my contacts, they are not listed. If I use their name to start a text discussion, their name and number show in the 'search' like if they were in the contacts.

  • 1
    Do you have a contact stored for all of the people you are messaging? – YusaMac205 Aug 2 '17 at 13:00
2

I've seen this happen to me before. To fix it for myself I've had to disable iCloud Contacts and then enable them.

Although, it might be best to restart your device before disabling and then reenabling your iCloud contacts?

Steps:

  1. Settings
  2. Apple ID (top of settings)
  3. iCloud (2nd set, 1st item)
  4. Toggle contacts switch to disable
  5. Delete from My iPhone
  6. Toggle contacts switch to reenable
  • 1
    @steph Please mark as answered if it worked. – Number1 Feb 22 '18 at 16:27
2

My smart husband figured out this answer. The Apple Experts could not figure it out.

  1. Go to Settings > General > Language > Select English (US) even if it is already selected.
  2. Next you will see a popup at the bottom of the page: "Change to English (US)"/"Cancel"
  3. Select "Change to English (US)"

Just wanted to post this if anyone else is having this problem.

Thanks, Vivian

You must log in to answer this question.

protected by Community Oct 22 '18 at 18:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .