1

Recently I have changed the name of my admin, and took off the password.

at the beginning everything looked right. However, when I turned off my MacBook Pro 2017, and turned it on again,now it gives me only access to the guest mode, and my admin account doesn't available to enter at all, and the only options that I have is to enter/click the guest mode, sleep restart, and turn off the computer. I also tried to do some changes in Users & Groups. However, cause I'm in a guest mode, so I need to click (unlock to make change) and Mac just refuses to accept any username, or password.

  • Is FileVault enabled (is your user account or disk encrypted)? – NoahL Aug 2 '17 at 15:06
  • Noahl thank you for your concern, but i have already solved the problem. at the end, i had to reinstall my MAC to solve it – Daniel Cuperman Aug 2 '17 at 22:28
1

You could try resetting the password: How do I recover the administrator or root password on OS X?

If that doesn't work, you would want to reboot in single user mode and then remove the /var/db/.AppleSetupDone file and make a new admin user. Once you can boot and make changes to the system, you can see about backing up, patching up the user account and getting back in business.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .