My Macbook pro got disabled. I tried to go into the recovery mode using cmd+R and internet recovery mode using cmd+opt+R. Both ask for my firmware password, and when I enter the password,although correct, it takes me back to disabled screen. Find my Iphone app says my Macbook is locked.In addition I tried to reinstall OS through bootable installer but that too takes me back to the disabled screen.

enter image description here

  • 1
    What do you mean by your macbook is disabled? Please send a screenshot of what’s showing on your computer. – Jackson1442 Jul 31 '17 at 23:27
  • When you say “got disabled” that means someone signed in to the same iCloud account as was entered as an admin user on that Mac and chose a specific numeric passcode. Was that not you? If not, I would get control of iCloud first - then worry about the firmware password. – bmike Aug 1 '17 at 10:50

If you are indeed locked out due to the FirmwarePasswordUtility preventing you from Internet Recovery mode, and cannot manage figuring out what your password is, there is still a last resort option.

Assuming you do actually own, and can prove you own the Mac, an official Apple Store can remove the firmware password and help you with restoring the computer to working condition.

| improve this answer | |

This lock is by design. It allows the owner to prevent anyone that can’t prove they own the hardware from getting Apple or other service professionals to erase the lock.

See https://www.apple.com/icloud/find-my-iphone/ and especially the Mac link at the bottom.

You now have a firmware password on that Mac preventing you from changing the OS to boot from other sources. You can either enter the passcode that was created to lock the hardware or follow the normal process when you forget a firmware password by seeking authorized service.

| improve this answer | |
  • I tried entering the firmware password but I am still stuck in this loop – Abhijeet Kairon Aug 1 '17 at 16:57
  • @AbhijeetKairon If you can't get the password to work, then you do need to seek service from an Apple Provider. – bmike Nov 9 '18 at 20:39

You can do the startup that takes you to disk utility to get to terminal and type in the terminal command to reset your login password.

| improve this answer | |
  • The question is about the firmware password, not the user account password. – wateroverflow9102 Aug 1 '17 at 8:59
  • As i mentioned i cant startup into that mode – Abhijeet Kairon Aug 1 '17 at 10:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .