I'm running Sparrow mail client and would love to disable Mail.app, which keeps opening from time to time.

  • 2
    What prompts it to open from time to time?
    – Daniel
    Nov 9 '11 at 4:38

You could try selecting the Mail icon in the Applications folder, select Get Info (I), and under permissions, set Everyone to no access. That should prevent the program from launching.

  • 3
    I found it was in fact my Google Calendar. I had email events 12 hours before each event, and somehow when I syncronized it with iCloud, it made Mail.app open and send an email. Nov 10 '11 at 5:20
  • 1
    This is the best answer for Lion, since Mail will not even allow the user to set preferences until they set up email accounts in the app.
    – Rab
    Jan 25 '12 at 16:07

From Apple Support, the steps to switch to a different mail reader are:

  1. Open Mail (/Applications/Mail)
  2. From the Mail menu, choose Preferences
  3. Click the General button
  4. Choose your desired default email application from the "Default email reader" pop-up menu.

This article also provides instructions to change the default mail app by editing the appropriate plist configuration.

To change the default email application, use Webmailer. This Apple.SE post has several answers that discuss the use of this utility.

  • I'm sorry for the late answer, but this doesn't work or address my issue. My default email reader is already configured there. Mail.app doesn't open when I click a mailto link, it just opens from time to time. I'm not sure why and uninstalling seems not to be possible. This is my first Mac so maybe there is something silly we should change. In case you need any other details, please let me know. Nov 6 '11 at 8:14
  • 1
    Note that there are some applications which are "hard coded" to use Mail.app and which do not honor the "Default Mail application" setting, including many of Apple's own apps.
    – TJ Luoma
    Nov 27 '11 at 22:34

I think you can uninstall the mail app using [CleanMyMac. I did this on an older version of OSX without any problems afterwards.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .