My internet connection is lame and the last time I tried to update with the download through App store, it downloaded and restarted but said that the verification of the update package was unsuccessful . I don't want to do that again .

So, I have manually downloaded the update package (1.55 GB) from http://supportdownload.apple.com. Now how do I update Mac OS , and also I don't want the verification failed kind of error. I also do know that this happens at some cases when OSx needs to be installed through the recovery section and you sure can fix it changing the systems date, but how do I do it in this case?

  • 1
    Did you get an actual verification failed error from the link or is this a hypothetical, you wish to avoid an error. What you are trying should work fine so it's unclear if you have a network / disk failure or are just asking if your plan is worth trying.
    – bmike
    Jul 29, 2017 at 13:47
  • 2
    To add to what @bmike said, it appears you have already downloaded the proper Combo Update package. You can simply double-click that dmg file, which will automatically mount a volume containing the installation package. Open that volume, and launch the installer.
    – user11633
    Jul 29, 2017 at 13:59

1 Answer 1


You can get the dmg file from here: https://support.apple.com/downloads/macos

While downloading the dmg please check the system requirement. Because you will need a combo dmg file if you are upgrading from say 10.11 to 10.11.6

On detail page of the dmg there is a System Requirements button at the bottom, please check the system requirement from there.


enter image description here

Source: Ask Different

  • yeah, but where the heck is the download button? there is a text called download icon inside a box but its just dead
    – xXREKTERxX
    Jul 29, 2017 at 13:18
  • @Anon click on that button and the download will start automatically.
    – PSN
    Jul 29, 2017 at 13:29
  • @Anon Its not dead. Try again.
    – PSN
    Jul 29, 2017 at 13:38
  • The link is dead when I opened it on OSX 10.6, but worked on macOS 10.13.
    – Aea
    Aug 29, 2018 at 21:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .